aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/package-index.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/package-index.bb')
-rw-r--r--meta/recipes-core/meta/package-index.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/package-index.bb b/meta/recipes-core/meta/package-index.bb
new file mode 100644
index 0000000000..21822fe9da
--- /dev/null
+++ b/meta/recipes-core/meta/package-index.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Rebuild the package index"
+LICENSE = "MIT"
+
+INHIBIT_DEFAULT_DEPS = "1"
+ALLOW_EMPTY = "1"
+PACKAGES = ""
+
+do_fetch() {
+}
+do_unpack() {
+}
+do_patch() {
+}
+do_configure() {
+}
+do_compile() {
+}
+do_install() {
+}
+
+do_build[nostamp] = "1"
+do_build[dirs] = "${DEPLOY_DIR_IPK}"
+do_build() {
+ set -ex
+ package_update_index_ipk
+ set +ex
+}
+
+EXCLUDE_FROM_WORLD = "1"