aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/images')
-rw-r--r--meta/recipes-core/images/core-image-core.bb2
-rw-r--r--meta/recipes-core/images/core-image-minimal-dev.bb3
-rw-r--r--meta/recipes-core/images/core-image-minimal-initramfs.bb6
-rw-r--r--meta/recipes-core/images/core-image-minimal-mtdutils.bb6
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb1
5 files changed, 10 insertions, 8 deletions
diff --git a/meta/recipes-core/images/core-image-core.bb b/meta/recipes-core/images/core-image-core.bb
index 2d768e0b78..ae32be8b48 100644
--- a/meta/recipes-core/images/core-image-core.bb
+++ b/meta/recipes-core/images/core-image-core.bb
@@ -1,7 +1,7 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "An X11 image with simple applications such as terminal, editor \
+DESCRIPTION = "An X11 image with simple applications such as terminal, editor, \
and file manager."
IMAGE_FEATURES += "apps-console-core ${X11_IMAGE_FEATURES}"
diff --git a/meta/recipes-core/images/core-image-minimal-dev.bb b/meta/recipes-core/images/core-image-minimal-dev.bb
index 3a0a1879ec..67c7790f00 100644
--- a/meta/recipes-core/images/core-image-minimal-dev.bb
+++ b/meta/recipes-core/images/core-image-minimal-dev.bb
@@ -1,7 +1,8 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "A core-image-minimal image suitable for development work."
+DESCRIPTION = "A small image just capable of allowing a device to boot and \
+is suitable for development work."
IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE}"
diff --git a/meta/recipes-core/images/core-image-minimal-initramfs.bb b/meta/recipes-core/images/core-image-minimal-initramfs.bb
index 85b9ff9b3f..4aeb6188f7 100644
--- a/meta/recipes-core/images/core-image-minimal-initramfs.bb
+++ b/meta/recipes-core/images/core-image-minimal-initramfs.bb
@@ -1,7 +1,7 @@
# Simple initramfs image. Mostly used for live images.
-DESCRIPTION = "A core-image-minimal image that has the Minimal RAM-based \
-Initial Root Filesystem (initramfs) as part of the kernel, which allows the \
-system to find the first 'init' program more efficiently."
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
+first “init” program more efficiently."
IMAGE_INSTALL = "initramfs-live-boot initramfs-live-install busybox udev base-passwd"
diff --git a/meta/recipes-core/images/core-image-minimal-mtdutils.bb b/meta/recipes-core/images/core-image-minimal-mtdutils.bb
index df2fab1f2c..331f16ca97 100644
--- a/meta/recipes-core/images/core-image-minimal-mtdutils.bb
+++ b/meta/recipes-core/images/core-image-minimal-mtdutils.bb
@@ -3,8 +3,8 @@
#
require core-image-minimal.bb
-DESCRIPTION = "A core-image-minimal image that supports the Minimal MTD \
-Utilities, which let the user interact with the MTD subsystem in the kernel \
-to perform operations on flash devices."
+DESCRIPTION = "Small image capable of booting a device with support for the \
+Minimal MTD Utilities, which let the user interact with the MTD subsystem in \
+the kernel to perform operations on flash devices."
IMAGE_INSTALL += "mtd-utils"
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index 1db6a7a3b2..cf3ef5fd24 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -1,3 +1,4 @@
+DESCRIPTION = "Version 1.0-r6 of the self-hosted image."
IMAGE_INSTALL = "task-core-boot task-core-apps-console task-core-ssh-openssh task-self-hosted"
LICENSE = "MIT"