aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch28
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch25
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch24
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/no-iconv.patch2
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch53
5 files changed, 65 insertions, 67 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch b/meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch
deleted file mode 100644
index 5c0afbce71..0000000000
--- a/meta/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 3d371334d5668bcd02a38ff99884bd343c244d68 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Sat, 18 Jun 2011 23:51:35 +0200
-Subject: [PATCH 3/7] gatomic-proper-pointer-get-cast.patch
-
-Upstream-Status: Pending
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
- glib/gatomic.h | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/glib/gatomic.h b/glib/gatomic.h
-index ddd39b8..b758142 100644
---- a/glib/gatomic.h
-+++ b/glib/gatomic.h
-@@ -70,7 +70,7 @@ void g_atomic_pointer_set (volatile gpointer G_GNUC_MAY_ALI
- (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
- # define g_atomic_pointer_get(atomic) \
- ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
-- (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
-+ (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void G_GNUC_MAY_ALIAS *) (atomic)))
- # define g_atomic_pointer_set(atomic, newval) \
- ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
- (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
---
-1.6.6.1
-
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch b/meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch
deleted file mode 100644
index db9a7993b2..0000000000
--- a/meta/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From a8e5c4a808e7f8572bd5023645a6cb4386b9aff8 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Sat, 18 Jun 2011 23:52:17 +0200
-Subject: [PATCH 5/7] don't leak buildpaths into perl hashbang
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
- gobject/glib-mkenums.in | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/gobject/glib-mkenums.in b/gobject/glib-mkenums.in
-index 6372245..b486fe9 100755
---- a/gobject/glib-mkenums.in
-+++ b/gobject/glib-mkenums.in
-@@ -1,4 +1,4 @@
--#! @PERL_PATH@
-+#! /usr/bin/env perl
-
- use warnings;
- use File::Basename;
---
-1.6.6.1
-
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch b/meta/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch
index b65a47462a..4ff7b80075 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch
+++ b/meta/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch
@@ -4,9 +4,9 @@ Rebased for glib-2.27.3 by Dongxiao Xu <dongxiao.xu@intel.com>, 11/16/2010
Upstream-Status: Inappropriate [patches for test code]
-diff -ruN glib-2.27.3-orig/tests/threadpool-test.c glib-2.27.3/tests/threadpool-test.c
---- glib-2.27.3-orig/tests/threadpool-test.c 2009-04-01 07:04:21.000000000 +0800
-+++ glib-2.27.3/tests/threadpool-test.c 2010-11-16 12:28:09.002172678 +0800
+diff -ruN glib-2.30.0-orig/tests/threadpool-test.c glib-2.30.0/tests/threadpool-test.c
+--- glib-2.30.0-orig/tests/threadpool-test.c 2009-04-01 07:04:21.000000000 +0800
++++ glib-2.30.0/tests/threadpool-test.c 2010-11-16 12:28:09.002172678 +0800
@@ -5,8 +5,8 @@
#include <glib.h>
@@ -18,16 +18,16 @@ diff -ruN glib-2.27.3-orig/tests/threadpool-test.c glib-2.27.3/tests/threadpool-
#define WAIT 5 /* seconds */
#define MAX_THREADS 10
-@@ -124,10 +124,10 @@
- DEBUG_MSG (("[unused] stopping unused threads"));
- g_thread_pool_stop_unused_threads ();
+@@ -130,10 +130,10 @@
+ test_count_threads () == 0)
+ break;
-- DEBUG_MSG (("[unused] waiting ONE second for threads to die"));
-+ DEBUG_MSG (("[unused] waiting FIVE second for threads to die"));
+- DEBUG_MSG (("[unused] waiting ONE second for threads to die"));
++ DEBUG_MSG (("[unused] waiting FIVE second for threads to die"));
- /* Some time for threads to die. */
-- g_usleep (G_USEC_PER_SEC);
-+ g_usleep (5 * G_USEC_PER_SEC);
+ /* Some time for threads to die. */
+- g_usleep (G_USEC_PER_SEC);
++ g_usleep (5 * G_USEC_PER_SEC);
+ }
DEBUG_MSG (("[unused] stopped idle threads, %d remain, %d threads still exist",
- g_thread_pool_get_num_unused_threads (),
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/no-iconv.patch b/meta/recipes-core/glib-2.0/glib-2.0/no-iconv.patch
index a1001922be..cca57d4f78 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0/no-iconv.patch
+++ b/meta/recipes-core/glib-2.0/glib-2.0/no-iconv.patch
@@ -6,8 +6,6 @@ impact on case when they are available.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Inappropriate [embedded specific]
-
Index: glib-2.26.1/glib/gconvert.c
===================================================================
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch b/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
new file mode 100644
index 0000000000..5c0a07abb1
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
@@ -0,0 +1,53 @@
+while cross compiling we cannot execute run tests
+
+Upstream-Status: Inappropriate [configuration]
+
+--- glib-2.30.0.orig/configure.ac 2011-09-29 16:57:35.000000000 +0200
++++ glib-2.30.0/configure.ac 2011-09-29 17:00:19.931493488 +0200
+@@ -586,45 +586,7 @@
+ dnl until we have checked this function is actually usable
+ AC_CHECK_FUNC([qsort_r])
+
+-# BSD has a qsort_r with wrong argument order
+-if test x$ac_cv_func_qsort_r = xyes ; then
+- AC_CACHE_CHECK([if qsort_r uses glibc compatible argument order], glib_cv_have_qsort_r, [
+- AC_RUN_IFELSE([AC_LANG_SOURCE([[
+- #define _GNU_SOURCE
+- #include <stdlib.h>
+-
+- static int
+- cmp (const void *a, const void *b, void *c)
+- {
+- const int *ia = a;
+- const int *ib = b;
+-
+- if (*ia < *ib)
+- return -1;
+- else if (*ia > *ib)
+- return 1;
+- else
+- return 0;
+- }
+-
+- int
+- main (int argc, char **argv)
+- {
+- int arr[3] = { 1, 2, 0 };
+- int d = 3;
+-
+- qsort_r (arr, 3, sizeof (int), cmp, &d);
+-
+- if (arr[0] == 0 && arr[1] == 1 && arr[2] == 2)
+- return 0;
+- else
+- return 1;
+- }]])],[glib_cv_have_qsort_r=yes],[glib_cv_have_qsort_r=no])])
+-fi
+-
+-if test x$glib_cv_have_qsort_r = xyes ; then
+- AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
+-fi
++AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
+
+ AC_CHECK_SIZEOF(char)
+ AC_CHECK_SIZEOF(short)