aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch56
1 files changed, 28 insertions, 28 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch b/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch
index e9b3b26a27..0149767a16 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch
+++ b/meta/recipes-core/glib-2.0/glib-2.0/nolibelf.patch
@@ -1,37 +1,37 @@
-Ideally there would be configureation option for this but there is not. We
-can't allow this code since it could detect the host system's libelf with
-disasterous effects when cross compiling.
+From 0040842024725c0e74f84c1719ead6c79ba94aba Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Wed, 16 May 2012 20:03:34 +0200
+Subject: [PATCH] configure: add option to disable libelf support
-RP 2012/5/7
+Upstream-Status: Pending
-Upstream-Status: Pending (would need to be made a configure option to disabe)
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ configure.ac | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
-Index: glib-2.32.2/configure.ac
-===================================================================
---- glib-2.32.2.orig/configure.ac 2012-05-07 08:30:04.481149925 +0000
-+++ glib-2.32.2/configure.ac 2012-05-07 08:31:02.185148588 +0000
-@@ -1816,23 +1816,7 @@
+diff --git a/configure.ac b/configure.ac
+index aa65648..1bb49bf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1815,6 +1815,9 @@ AC_SUBST(XATTR_LIBS)
+ dnl ************************
dnl *** check for libelf ***
dnl ************************
++AC_ARG_ENABLE(libelf,
++ AC_HELP_STRING([--disable-libelf], [build without libelf support]))
++if test "x$enable_libelf" != "xno"; then
+
+ PKG_CHECK_MODULES([LIBELF], [libelf], [have_libelf=yes], [have_libelf=maybe])
--PKG_CHECK_MODULES([LIBELF], [libelf], [have_libelf=yes], [have_libelf=maybe])
--
--if test $have_libelf = maybe; then
-- AC_CHECK_LIB([elf], [elf_begin], , [have_libelf=no])
-- AC_CHECK_LIB([elf], [elf_getshdrstrndx], , [have_libelf=no])
-- AC_CHECK_LIB([elf], [elf_getshdrnum], , [have_libelf=no])
-- AC_CHECK_HEADER([libelf.h], , [have_libelf=no])
--
-- if test $have_libelf != no; then
-- LIBELF_LIBS=-lelf
-- have_libelf = yes
-- fi
--fi
--
--if test $have_libelf = yes; then
-- AC_DEFINE(HAVE_LIBELF, 1, [Define if libelf is available])
--fi
-+have_libelf=no
+@@ -1835,6 +1838,7 @@ fi
+ if test $have_libelf = yes; then
+ AC_DEFINE(HAVE_LIBELF, 1, [Define if libelf is available])
+ fi
++fi
dnl ****************************************
dnl *** platform dependent source checks ***
+--
+1.7.8.6
+