aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dbus')
-rw-r--r--meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init121
-rw-r--r--meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch56
-rw-r--r--meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch34
-rw-r--r--meta/recipes-core/dbus/dbus-glib-0.86/fix_asneeded.patch17
-rw-r--r--meta/recipes-core/dbus/dbus-glib-0.86/no-examples.patch12
-rw-r--r--meta/recipes-core/dbus/dbus-glib.inc23
-rw-r--r--meta/recipes-core/dbus/dbus-glib_0.86.bb3
-rw-r--r--meta/recipes-core/dbus/dbus.inc91
-rw-r--r--meta/recipes-core/dbus/dbus_1.2.24.bb3
9 files changed, 360 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init b/meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init
new file mode 100644
index 0000000000..4abc4cbf73
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.2.24/dbus-1.init
@@ -0,0 +1,121 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides: dbus
+# Required-Start: $remote_fs $syslog
+# Required-Stop: $remote_fs $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 1
+# Short-Description: D-Bus systemwide message bus
+# Description: D-Bus is a simple interprocess messaging system, used
+# for sending messages between applications.
+### END INIT INFO
+#
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon
+NAME=dbus
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+UUIDDIR=/var/lib/dbus
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus ]; then
+ . /etc/default/dbus
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+
+ if [ ! -d $UUIDDIR ]; then
+ mkdir -p $UUIDDIR
+ chown $DAEMONUSER $UUIDDIR
+ chgrp $DAEMONUSER $UUIDDIR
+ fi
+
+ dbus-uuidgen --ensure
+
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ # TODO: --reverse when busybox supports it
+ run-parts --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+reload_it()
+{
+ echo -n "Reloading $DESC config: "
+ dbus-send --print-reply --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig > /dev/null
+ # hopefully this is enough time for dbus to reload it's config file.
+ echo "done."
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ reload|force-reload)
+ reload_it
+ ;;
+ restart)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch b/meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch
new file mode 100644
index 0000000000..edb63a5faf
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.2.24/fix-install-daemon.patch
@@ -0,0 +1,56 @@
+# Update fix-daemon-install patch to use automake magic to avoid the wrapper scripts
+#
+# original by RP, updated to handle dbus-daemon-launch-helper by Kevin Tian <kevin.tian@intel.com>, 2010-07-10
+Index: dbus-1.2.14/bus/Makefile.am
+===================================================================
+--- dbus-1.2.14.orig/bus/Makefile.am 2009-04-17 20:45:29.000000000 +0100
++++ dbus-1.2.14/bus/Makefile.am 2009-11-13 09:47:24.000000000 +0000
+@@ -149,7 +149,7 @@ endif
+
+ ## we use noinst_PROGRAMS not check_PROGRAMS so that we build
+ ## even when not doing "make check"
+-noinst_PROGRAMS=$(TESTS) dbus-daemon dbus-daemon-launch-helper-test dbus-daemon-launch-helper
++noinst_PROGRAMS=$(TESTS) dbus-daemon-launch-helper-test
+
+ bus_test_system_SOURCES= \
+ $(XML_SOURCES) \
+@@ -171,34 +171,22 @@ bus_test_SOURCES= \
+ bus_test_LDADD=$(top_builddir)/dbus/libdbus-convenience.la $(DBUS_BUS_LIBS)
+ bus_test_LDFLAGS=@R_DYNAMIC_LDFLAG@
+
++dbusdaemondir = $(DBUS_DAEMONDIR)
++dbusdaemon_PROGRAMS = dbus-daemon
++
++libexec_PROGRAMS = dbus-daemon-launch-helper
++
+ ## mop up the gcov files
+ clean-local:
+ /bin/rm *.bb *.bbg *.da *.gcov || true
+
+-uninstall-hook:
+- rm -f $(DESTDIR)$(DBUS_DAEMONDIR)/dbus-daemon
+- rm -f $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper
+-
+ install-data-hook:
+- if test '!' -d $(DESTDIR)$(DBUS_DAEMONDIR); then \
+- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
+- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
+- fi
+- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/session.d
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services
+ $(mkinstalldirs) $(DESTDIR)$(libexecdir)/dbus-1
+- $(INSTALL_PROGRAM) dbus-daemon-launch-helper $(DESTDIR)$(libexecdir)
+- if test `id -u` -eq 0; then \
+- chown root:$(DBUS_USER) $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
+- chmod 4750 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper; \
+- else \
+- echo "Not installing $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper binary setuid!"; \
+- echo "You'll need to manually set permissions to root:$(DBUS_USER) and permissions 4750"; \
+- fi
+
+ #### Init scripts fun
+ SCRIPT_IN_FILES=messagebus.in \
diff --git a/meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch b/meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch
new file mode 100644
index 0000000000..f5c22af129
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-1.2.24/tmpdir.patch
@@ -0,0 +1,34 @@
+# avoid to check tmp dir at build time. instead uses hard coded /tmp here
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>
+
+--- dbus-0.22/configure.in.orig 2004-08-13 00:57:16.000000000 +0200
++++ dbus-0.22/configure.in 2004-12-30 21:15:57.000000000 +0100
+@@ -1047,15 +1048,18 @@
+ AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
+
+ #### Find socket directories
+-if ! test -z "$TMPDIR" ; then
+- DEFAULT_SOCKET_DIR=$TMPDIR
+-elif ! test -z "$TEMP" ; then
+- DEFAULT_SOCKET_DIR=$TEMP
+-elif ! test -z "$TMP" ; then
+- DEFAULT_SOCKET_DIR=$TMP
+-else
+- DEFAULT_SOCKET_DIR=/tmp
+-fi
++#if ! test -z "$TMPDIR" ; then
++# DEFAULT_SOCKET_DIR=$TMPDIR
++#elif ! test -z "$TEMP" ; then
++# DEFAULT_SOCKET_DIR=$TEMP
++#elif ! test -z "$TMP" ; then
++# DEFAULT_SOCKET_DIR=$TMP
++#else
++# DEFAULT_SOCKET_DIR=/tmp
++#fi
++
++# checks disabled to avoid expanding this at build time
++DEFAULT_SOCKET_DIR=/tmp
+
+ if ! test -z "$with_test_socket_dir" ; then
+ TEST_SOCKET_DIR="$with_test_socket_dir"
diff --git a/meta/recipes-core/dbus/dbus-glib-0.86/fix_asneeded.patch b/meta/recipes-core/dbus/dbus-glib-0.86/fix_asneeded.patch
new file mode 100644
index 0000000000..3065557683
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-glib-0.86/fix_asneeded.patch
@@ -0,0 +1,17 @@
+# not sure the reason for changing link order. Disable it for now, but keep for a while
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-10
+
+Index: dbus-glib-0.82/dbus/Makefile.am
+===================================================================
+--- dbus-glib-0.82.orig/dbus/Makefile.am 2009-07-16 15:54:44.000000000 +0100
++++ dbus-glib-0.82/dbus/Makefile.am 2009-12-11 09:27:20.000000000 +0000
+@@ -105,7 +105,7 @@
+
+ dbus_bash_completion_helper_SOURCES = \
+ dbus-bash-completion-helper.c
+-dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) $(builddir)/libdbus-gtool.la -lexpat $(builddir)/libdbus-glib-1.la
++dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) $(builddir)/libdbus-gtool.la $(builddir)/libdbus-glib-1.la -lexpat
+
+
+ EXTRA_DIST=dbus-gmarshal.list make-dbus-glib-error-switch.sh make-dbus-glib-error-enum.sh dbus-bash-completion.sh.in
diff --git a/meta/recipes-core/dbus/dbus-glib-0.86/no-examples.patch b/meta/recipes-core/dbus/dbus-glib-0.86/no-examples.patch
new file mode 100644
index 0000000000..32609b9b9c
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-glib-0.86/no-examples.patch
@@ -0,0 +1,12 @@
+# disable compiling examples
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-10
+
+--- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/meta/recipes-core/dbus/dbus-glib.inc b/meta/recipes-core/dbus/dbus-glib.inc
new file mode 100644
index 0000000000..985c565e8b
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-glib.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "high level language (glib) binding for dbus"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "AFL2.1 | GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cf5b3a2f7083750d504333114e738656 \
+ file://dbus/dbus-glib.h;firstline=7;endline=21;md5=833ef01806b4c524fb3678a16300536f"
+SECTION = "base"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+DEPENDS_virtclass-native = "glib-2.0-native dbus-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://no-examples.patch"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
+
+EXTRA_OECONF = "--with-introspect-xml=${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml \
+ --with-dbus-binding-tool=${STAGING_BINDIR_NATIVE}/dbus-binding-tool"
+EXTRA_OECONF_virtclass-native = "--with-introspect-xml=${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-core/dbus/dbus-glib_0.86.bb b/meta/recipes-core/dbus/dbus-glib_0.86.bb
new file mode 100644
index 0000000000..000146ab7e
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-glib_0.86.bb
@@ -0,0 +1,3 @@
+require dbus-glib.inc
+
+PR = "r0"
diff --git a/meta/recipes-core/dbus/dbus.inc b/meta/recipes-core/dbus/dbus.inc
new file mode 100644
index 0000000000..90a38e66a9
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus.inc
@@ -0,0 +1,91 @@
+DESCRIPTION = "D-Bus is a message bus system, a simple way for applications to talk to one another. In addition to interprocess communication, D-Bus helps coordinate process lifecycle; it makes it simple and reliable to code a \"single instance\" application or daemon, and to launch applications and daemons on demand when their services are needed"
+HOMEPAGE = "http://dbus.freedesktop.org"
+SECTION = "base"
+LICENSE = "AFL2.1 | GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
+ file://dbus/dbus.h;firstline=6;endline=20;md5=6eea2e0c7750dd8e620dcb1437312fa5"
+DEPENDS = "expat glib-2.0 virtual/libintl virtual/libx11 libsm"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch; \
+ file://fix-install-daemon.patch; \
+ file://dbus-1.init"
+
+inherit autotools pkgconfig gettext update-rc.d
+
+INITSCRIPT_NAME = "dbus-1"
+INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ."
+
+CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
+
+DEBIANNAME_${PN} = "dbus-1"
+
+PACKAGES =+ "${PN}-lib"
+
+FILES_${PN} = "${bindir}/dbus-daemon* \
+ ${bindir}/dbus-uuidgen \
+ ${bindir}/dbus-launch \
+ ${bindir}/dbus-cleanup-sockets \
+ ${bindir}/dbus-send \
+ ${bindir}/dbus-monitor \
+ ${libexecdir}/dbus* \
+ ${sysconfdir} \
+ ${datadir}/dbus-1/services \
+ ${datadir}/dbus-1/system-services"
+FILES_${PN}-lib = "${libdir}/lib*.so.*"
+RRECOMMENDS_${PN}-lib = "${PN}"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+pkg_postinst_dbus() {
+ # can't do adduser stuff offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ MESSAGEUSER=messagebus
+ MESSAGEHOME=/var/run/dbus
+
+ mkdir -p $MESSAGEHOME || true
+ chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
+ chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || \
+ adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password \
+ --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
+
+ grep -q netdev: /etc/group || addgroup netdev
+ chmod u+s /usr/libexec/dbus-daemon-launch-helper
+
+ # add volatile after new user/grp are created
+ echo "d messagebus messagebus 0755 /var/run/dbus none" > /etc/default/volatiles/99_dbus
+ /etc/init.d/populate-volatile.sh update
+}
+
+EXTRA_OECONF_X = "--with-x"
+EXTRA_OECONF_X_virtclass-native = "--without-x"
+
+EXTRA_OECONF = "--disable-tests \
+ --disable-checks \
+ --disable-xml-docs \
+ --disable-doxygen-docs \
+ --disable-libaudit \
+ --with-xml=expat \
+ ${EXTRA_OECONF_X}"
+
+do_install() {
+ autotools_do_install
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
+}
+
+do_install_virtclass-native() {
+ autotools_do_install
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR_NATIVE}/dbus/
+ # N.B. is below install actually required?
+ install -m 0644 bus/session.conf ${STAGING_DATADIR_NATIVE}/dbus/session.conf
+
+ # dbus-glib-native and dbus-glib need this xml file
+ ./bus/dbus-daemon --introspect > ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml
+}
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-core/dbus/dbus_1.2.24.bb b/meta/recipes-core/dbus/dbus_1.2.24.bb
new file mode 100644
index 0000000000..8e3e329fde
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus_1.2.24.bb
@@ -0,0 +1,3 @@
+include dbus.inc
+
+PR = "r1"