summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ofono/ofono/0001-build-Fix-a-race-condition.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/ofono/ofono/0001-build-Fix-a-race-condition.patch')
-rw-r--r--meta/recipes-connectivity/ofono/ofono/0001-build-Fix-a-race-condition.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ofono/ofono/0001-build-Fix-a-race-condition.patch b/meta/recipes-connectivity/ofono/ofono/0001-build-Fix-a-race-condition.patch
new file mode 100644
index 0000000000..2e2aa88265
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono/0001-build-Fix-a-race-condition.patch
@@ -0,0 +1,28 @@
+From 3e43e3342f3fada1624a28500a5337019fed7d89 Mon Sep 17 00:00:00 2001
+From: Adrian Bunk <bunk@kernel.org>
+Date: Thu, 9 May 2019 12:19:51 +0300
+Subject: build: Fix a race condition
+
+ell/ell.h was written before ell/ existed
+
+Upstream-Status: Backport
+Signed-off-by: Adrian Bunk <bunk@stusta.de>
+---
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index a569c4a3..d2e310d5 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1107,6 +1107,7 @@ ell/internal: Makefile
+ done > $@
+
+ ell/ell.h: Makefile
++ $(AM_V_at)$(MKDIR_P) ell
+ $(AM_V_at)echo -n > $@
+ $(AM_V_GEN)for f in $(ell_headers) ; do \
+ echo "#include <$$f>" >> $@ ; \
+--
+2.20.1
+