aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/gypsy
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/gypsy')
-rw-r--r--meta/recipes-connectivity/gypsy/files/fixups.patch19
-rw-r--r--meta/recipes-connectivity/gypsy/gypsy.inc14
-rw-r--r--meta/recipes-connectivity/gypsy/gypsy_0.6.bb10
-rw-r--r--meta/recipes-connectivity/gypsy/gypsy_svn.bb9
4 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/gypsy/files/fixups.patch b/meta/recipes-connectivity/gypsy/files/fixups.patch
new file mode 100644
index 0000000000..8bc8c5cbac
--- /dev/null
+++ b/meta/recipes-connectivity/gypsy/files/fixups.patch
@@ -0,0 +1,19 @@
+---
+ docs/reference/Makefile.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- gypsy.orig/docs/reference/Makefile.am
++++ gypsy/docs/reference/Makefile.am
+@@ -81,10 +81,12 @@ expand_content_files=
+ # e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
+
+ INCLUDES=-I$(top_srcdir) $(GYPSY_CFLAGS)
+ GTKDOC_LIBS=$(top_builddir)/gypsy/libgypsy.la $(GYPSY_LIBS)
+
++EXTRA_DIST =
++CLEANFILES =
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+ include $(top_srcdir)/gtk-doc.make
+
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
diff --git a/meta/recipes-connectivity/gypsy/gypsy.inc b/meta/recipes-connectivity/gypsy/gypsy.inc
new file mode 100644
index 0000000000..f0d90b290e
--- /dev/null
+++ b/meta/recipes-connectivity/gypsy/gypsy.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "GPS Controlling Daemon"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 dbus bluez4 dbus-glib"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--with-distro=debian"
+
+do_configure_prepend () {
+ touch ${S}/gtk-doc.make
+}
+
+FILES_${PN} += "/usr/share/dbus-1/services/"
diff --git a/meta/recipes-connectivity/gypsy/gypsy_0.6.bb b/meta/recipes-connectivity/gypsy/gypsy_0.6.bb
new file mode 100644
index 0000000000..ee669e5ef4
--- /dev/null
+++ b/meta/recipes-connectivity/gypsy/gypsy_0.6.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "GPS Controlling Daemon"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt"
+
+SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "/usr/share/dbus-1/services/"
diff --git a/meta/recipes-connectivity/gypsy/gypsy_svn.bb b/meta/recipes-connectivity/gypsy/gypsy_svn.bb
new file mode 100644
index 0000000000..ac1b6bc12f
--- /dev/null
+++ b/meta/recipes-connectivity/gypsy/gypsy_svn.bb
@@ -0,0 +1,9 @@
+require gypsy.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.0+svnr${SRCREV}"
+S = "${WORKDIR}/${PN}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/trunk;module=${PN};proto=http \
+ file://fixups.patch;patch=1"