aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/usbinit
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/usbinit')
-rw-r--r--meta/recipes-bsp/usbinit/usbinit.bb18
-rwxr-xr-xmeta/recipes-bsp/usbinit/usbinit/usb-gether23
2 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-bsp/usbinit/usbinit.bb b/meta/recipes-bsp/usbinit/usbinit.bb
new file mode 100644
index 0000000000..1d4575bddb
--- /dev/null
+++ b/meta/recipes-bsp/usbinit/usbinit.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Initscript to manage gadget Ethernet"
+LICENSE = "GPL"
+PRIORITY = "optional"
+PR = "r1"
+
+SRC_URI = "file://usb-gether"
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/etc
+ install -d ${D}/etc/init.d
+ install usb-gether ${D}/etc/init.d
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "usb-gether"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/meta/recipes-bsp/usbinit/usbinit/usb-gether b/meta/recipes-bsp/usbinit/usbinit/usb-gether
new file mode 100755
index 0000000000..e80a0bb30e
--- /dev/null
+++ b/meta/recipes-bsp/usbinit/usbinit/usb-gether
@@ -0,0 +1,23 @@
+#! /bin/sh
+#
+# usb-ether Start up the gadget usb ethernet interface.
+#
+
+case "$1" in
+ start|"")
+ test "$VERBOSE" != no && echo "Initializing g_ether gadget..."
+ modprobe g_ether
+ ifup usb0
+ ;;
+ stop)
+ test "$VERBOSE" != no && echo "Disabling g_ether..."
+ ifdown usb0
+ rmmod g_ether
+ ;;
+ *)
+ echo "Usage: usb-ether {start|stop}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0