aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/yum
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/yum')
-rw-r--r--meta/packages/yum/createrepo-native/pathfix.patch81
-rw-r--r--meta/packages/yum/createrepo-native_0.9.8.bb17
-rw-r--r--meta/packages/yum/files/98_yum1
-rw-r--r--meta/packages/yum/files/extract-postinst.awk11
-rw-r--r--meta/packages/yum/files/fix18
-rw-r--r--meta/packages/yum/files/hacks.patch81
-rw-r--r--meta/packages/yum/files/paths.patch106
-rw-r--r--meta/packages/yum/files/paths2.patch35
-rwxr-xr-xmeta/packages/yum/files/yum-install-recommends.py39
-rw-r--r--meta/packages/yum/yum_3.2.27.bb46
10 files changed, 0 insertions, 435 deletions
diff --git a/meta/packages/yum/createrepo-native/pathfix.patch b/meta/packages/yum/createrepo-native/pathfix.patch
deleted file mode 100644
index a09a51ccc9..0000000000
--- a/meta/packages/yum/createrepo-native/pathfix.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-Index: createrepo-0.9/Makefile
-===================================================================
---- createrepo-0.9.orig/Makefile 2008-08-23 17:49:24.000000000 +0100
-+++ createrepo-0.9/Makefile 2008-08-23 17:52:01.000000000 +0100
-@@ -10,22 +10,6 @@
- SHELL = /bin/sh
- top_srcdir = .
- srcdir = .
--prefix = /usr
--exec_prefix = ${prefix}
--
--bindir = ${exec_prefix}/bin
--sbindir = ${exec_prefix}/sbin
--libexecdir = ${exec_prefix}/libexec
--datadir = ${prefix}/share
--sysconfdir = ${prefix}/etc
--sharedstatedir = ${prefix}/com
--localstatedir = ${prefix}/var
--libdir = ${exec_prefix}/lib
--infodir = ${prefix}/info
--docdir =
--includedir = ${prefix}/include
--oldincludedir = /usr/include
--mandir = ${prefix}/share/man
-
- pkgdatadir = $(datadir)/$(PKGNAME)
- pkglibdir = $(libdir)/$(PKGNAME)
-Index: createrepo-0.9/bin/Makefile
-===================================================================
---- createrepo-0.9.orig/bin/Makefile 2008-08-23 17:50:13.000000000 +0100
-+++ createrepo-0.9/bin/Makefile 2008-08-23 17:50:23.000000000 +0100
-@@ -1,22 +1,6 @@
- SHELL = /bin/sh
- top_srcdir = ..
- srcdir = ../bin
--prefix = /usr
--exec_prefix = ${prefix}
--
--bindir = ${exec_prefix}/bin
--sbindir = ${exec_prefix}/sbin
--libexecdir = ${exec_prefix}/libexec
--datadir = ${prefix}/share
--sysconfdir = ${prefix}/etc
--sharedstatedir = ${prefix}/com
--localstatedir = ${prefix}/var
--libdir = ${exec_prefix}/lib
--infodir = ${prefix}/info
--docdir =
--includedir = ${prefix}/include
--oldincludedir = /usr/include
--mandir = ${prefix}/man
-
- pkgdatadir = $(datadir)/$(PKGNAME)
- pkglibdir = $(libdir)/$(PKGNAME)
-Index: createrepo-0.9/docs/Makefile
-===================================================================
---- createrepo-0.9.orig/docs/Makefile 2008-08-23 17:52:42.000000000 +0100
-+++ createrepo-0.9/docs/Makefile 2008-08-23 17:52:50.000000000 +0100
-@@ -1,22 +1,6 @@
- SHELL = /bin/sh
- top_srcdir = ..
- srcdir = ../docs
--prefix = /usr
--exec_prefix = ${prefix}
--
--bindir = ${exec_prefix}/bin
--sbindir = ${exec_prefix}/sbin
--libexecdir = ${exec_prefix}/libexec
--datadir = ${prefix}/share
--sysconfdir = ${prefix}/etc
--sharedstatedir = ${prefix}/com
--localstatedir = ${prefix}/var
--libdir = ${exec_prefix}/lib
--infodir = ${prefix}/info
--docdir =
--includedir = ${prefix}/include
--oldincludedir = /usr/include
--mandir = ${datadir}/man
-
- pkgdatadir = $(datadir)/$(PKGNAME)
- pkglibdir = $(libdir)/$(PKGNAME)
diff --git a/meta/packages/yum/createrepo-native_0.9.8.bb b/meta/packages/yum/createrepo-native_0.9.8.bb
deleted file mode 100644
index 895f2e96fe..0000000000
--- a/meta/packages/yum/createrepo-native_0.9.8.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DEPENDS = "python-native libxml2-native"
-RDEPENDS = "yum-native"
-
-SRC_URI = "http://createrepo.baseurl.org/download/createrepo-${PV}.tar.gz \
- file://pathfix.patch;patch=1 "
-PR = "r2"
-
-inherit autotools native
-
-S = "${WORKDIR}/createrepo-${PV}"
-
-do_compile_append () {
- sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/createrepo
- sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/modifyrepo
- sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/genpkgmetadata.py
- sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/modifyrepo.py
-}
diff --git a/meta/packages/yum/files/98_yum b/meta/packages/yum/files/98_yum
deleted file mode 100644
index cb4047ad2b..0000000000
--- a/meta/packages/yum/files/98_yum
+++ /dev/null
@@ -1 +0,0 @@
-d root root 0755 /var/cache/yum none
diff --git a/meta/packages/yum/files/extract-postinst.awk b/meta/packages/yum/files/extract-postinst.awk
deleted file mode 100644
index 8f2836b32c..0000000000
--- a/meta/packages/yum/files/extract-postinst.awk
+++ /dev/null
@@ -1,11 +0,0 @@
-/Name:.*/ {
- package = substr($0, 7)
- next
-}
-/postinstall.*scriptlet .*/ {
- next
-}
-{
- print $0 >> ENVIRON["D"] "/etc/rpm-postinsts/" package ".sh"
-}
-
diff --git a/meta/packages/yum/files/fix b/meta/packages/yum/files/fix
deleted file mode 100644
index bcb3301e14..0000000000
--- a/meta/packages/yum/files/fix
+++ /dev/null
@@ -1,18 +0,0 @@
----
- rpmUtils/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- yum-3.2.18.orig/rpmUtils/Makefile
-+++ yum-3.2.18/rpmUtils/Makefile
-@@ -1,10 +1,10 @@
- PYTHON=python
- PACKAGE = $(shell basename `pwd`)
- PYFILES = $(wildcard *.py)
- PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
--PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
-+PYSYSDIR := /usr
- PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
-
- all:
- echo "Nothing to do"
diff --git a/meta/packages/yum/files/hacks.patch b/meta/packages/yum/files/hacks.patch
deleted file mode 100644
index 61f477172c..0000000000
--- a/meta/packages/yum/files/hacks.patch
+++ /dev/null
@@ -1,81 +0,0 @@
----
- rpmUtils/arch.py | 3 +++
- rpmUtils/transaction.py | 1 +
- yum/constants.py | 2 +-
- yum/depsolve.py | 2 ++
- 4 files changed, 7 insertions(+), 1 deletion(-)
-
-Index: yum-3.2.18/rpmUtils/arch.py
-===================================================================
---- yum-3.2.18.orig/rpmUtils/arch.py 2008-06-17 14:05:42.000000000 +0100
-+++ yum-3.2.18/rpmUtils/arch.py 2008-10-02 22:09:19.000000000 +0100
-@@ -275,6 +275,12 @@
- return arch
-
- def getCanonArch(skipRpmPlatform = 0):
-+ import os
-+ if 'YUM_ARCH_FORCE' in os.environ:
-+ return os.environ['YUM_ARCH_FORCE']
-+
-+ sys.exit(1)
-+
- if not skipRpmPlatform and os.access("/etc/rpm/platform", os.R_OK):
- try:
- f = open("/etc/rpm/platform", "r")
-@@ -331,6 +338,12 @@
- base arch is the arch before noarch in the arches dict if myarch is not
- a key in the multilibArches."""
-
-+ import os
-+ if 'YUM_ARCH_FORCE' in os.environ:
-+ return os.environ['YUM_ARCH_FORCE']
-+
-+ sys.exit(1)
-+
- if not myarch:
- myarch = canonArch
-
-Index: yum-3.2.18/rpmUtils/transaction.py
-===================================================================
---- yum-3.2.18.orig/rpmUtils/transaction.py 2008-06-17 14:05:42.000000000 +0100
-+++ yum-3.2.18/rpmUtils/transaction.py 2008-10-02 17:09:57.000000000 +0100
-@@ -43,6 +43,7 @@
- 'clean']
- self.tsflags = []
- self.open = True
-+ self.ts.setProbFilter(rpm.RPMPROB_FILTER_IGNOREOS | rpm.RPMPROB_FILTER_IGNOREARCH)
-
- def __del__(self):
- # Automatically close the rpm transaction when the reference is lost
-Index: yum-3.2.18/yum/constants.py
-===================================================================
---- yum-3.2.18.orig/yum/constants.py 2008-07-21 16:56:54.000000000 +0100
-+++ yum-3.2.18/yum/constants.py 2008-10-02 17:09:57.000000000 +0100
-@@ -17,7 +17,7 @@
- """
-
- #Constants
--YUM_PID_FILE = '/var/run/yum.pid'
-+YUM_PID_FILE = '/var/run2/yum.pid'
-
- #transaction set states
- TS_UPDATE = 10
-Index: yum-3.2.18/yum/depsolve.py
-===================================================================
---- yum-3.2.18.orig/yum/depsolve.py 2008-08-06 17:05:16.000000000 +0100
-+++ yum-3.2.18/yum/depsolve.py 2008-10-02 17:09:57.000000000 +0100
-@@ -141,9 +141,14 @@
- else:
- self.logger.critical(_('Invalid tsflag in config file: %s'), flag)
-
-+ self._ts.addTsFlag(rpm.RPMTRANS_FLAG_NOPOST)
-+ self._ts.addTsFlag(rpm.RPMTRANS_FLAG_NOTRIGGERS)
-+
- probfilter = 0
- for flag in self.tsInfo.probFilterFlags:
- probfilter |= flag
-+ probfilter |= rpm.RPMPROB_FILTER_IGNOREOS
-+ probfilter |= rpm.RPMPROB_FILTER_IGNOREARCH
- self._ts.setProbFilter(probfilter)
-
- def whatProvides(self, name, flags, version):
diff --git a/meta/packages/yum/files/paths.patch b/meta/packages/yum/files/paths.patch
deleted file mode 100644
index 0175d05b34..0000000000
--- a/meta/packages/yum/files/paths.patch
+++ /dev/null
@@ -1,106 +0,0 @@
----
- Makefile | 18 +++++++++---------
- docs/Makefile | 12 ++++++------
- etc/Makefile | 20 ++++++++++----------
- 3 files changed, 25 insertions(+), 25 deletions(-)
-
-Index: yum-3.2.27/Makefile
-===================================================================
---- yum-3.2.27.orig/Makefile 2010-03-04 01:10:20.000000000 +0000
-+++ yum-3.2.27/Makefile 2010-03-23 13:49:50.663912930 +0000
-@@ -22,19 +22,19 @@
- for d in $(SUBDIRS); do make PYTHON=$(PYTHON) -C $$d; [ $$? = 0 ] || exit 1 ; done
-
- install:
-- mkdir -p $(DESTDIR)/usr/share/yum-cli
-+ mkdir -p $(DESTDIR)$(datadir)/yum-cli
- for p in $(PYFILES) ; do \
-- install -m 644 $$p $(DESTDIR)/usr/share/yum-cli/$$p; \
-+ install -m 644 $$p $(DESTDIR)$(datadir)/yum-cli/$$p; \
- done
-- mv $(DESTDIR)/usr/share/yum-cli/yum-updatesd.py $(DESTDIR)/usr/share/yum-cli/yumupd.py
-- $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)/usr/share/yum-cli', 1, '$(PYDIR)', 1)"
-+ mv $(DESTDIR)$(datadir)/yum-cli/yum-updatesd.py $(DESTDIR)$(datadir)/yum-cli/yumupd.py
-+ $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)$(datadir)/yum-cli', 1, '$(PYDIR)', 1)"
-
-- mkdir -p $(DESTDIR)/usr/bin $(DESTDIR)/usr/sbin
-- install -m 755 bin/yum.py $(DESTDIR)/usr/bin/yum
-- install -m 755 bin/yum-updatesd.py $(DESTDIR)/usr/sbin/yum-updatesd
-+ mkdir -p $(DESTDIR)$(bindir) $(DESTDIR)$(sbindir)
-+ install -m 755 bin/yum.py $(DESTDIR)$(bindir)/yum
-+ install -m 755 bin/yum-updatesd.py $(DESTDIR)$(sbindir)/yum-updatesd
-
-- mkdir -p $(DESTDIR)/var/cache/yum
-- mkdir -p $(DESTDIR)/var/lib/yum
-+ mkdir -p $(DESTDIR)$(localstatedir)/cache/yum
-+ mkdir -p $(DESTDIR)$(localstatedir)/lib/yum
-
- for d in $(SUBDIRS); do make PYTHON=$(PYTHON) DESTDIR=`cd $(DESTDIR); pwd` -C $$d install; [ $$? = 0 ] || exit 1; done
-
-Index: yum-3.2.27/docs/Makefile
-===================================================================
---- yum-3.2.27.orig/docs/Makefile 2009-04-07 14:57:06.000000000 +0100
-+++ yum-3.2.27/docs/Makefile 2010-03-23 13:52:30.086667913 +0000
-@@ -6,10 +6,10 @@
- rm -fr epydoc
-
- install:
-- mkdir -p $(DESTDIR)/usr/share/man/man5
-- mkdir -p $(DESTDIR)/usr/share/man/man8
-- install -m 644 yum.8 $(DESTDIR)/usr/share/man/man8/yum.8
-- install -m 644 yum-shell.8 $(DESTDIR)/usr/share/man/man8/yum-shell.8
-- install -m 644 yum.conf.5 $(DESTDIR)/usr/share/man/man5/yum.conf.5
-- install -m 644 yum-updatesd.8 $(DESTDIR)/usr/share/man/man8/yum-updatesd.8
-- install -m 644 yum-updatesd.conf.5 $(DESTDIR)/usr/share/man/man5/yum-updatesd.conf.5
-+ mkdir -p $(DESTDIR)$(mandir)/man5
-+ mkdir -p $(DESTDIR)$(mandir)/man8
-+ install -m 644 yum.8 $(DESTDIR)$(mandir)/man8/yum.8
-+ install -m 644 yum-shell.8 $(DESTDIR)$(mandir)/man8/yum-shell.8
-+ install -m 644 yum.conf.5 $(DESTDIR)$(mandir)/man5/yum.conf.5
-+ install -m 644 yum-updatesd.8 $(DESTDIR)$(mandir)/man8/yum-updatesd.8
-+ install -m 644 yum-updatesd.conf.5 $(DESTDIR)$(mandir)/man5/yum-updatesd.conf.5
-Index: yum-3.2.27/etc/Makefile
-===================================================================
---- yum-3.2.27.orig/etc/Makefile 2009-10-26 18:56:06.000000000 +0000
-+++ yum-3.2.27/etc/Makefile 2010-03-23 13:54:40.421912460 +0000
-@@ -1,4 +1,4 @@
--YUMETC=$(DESTDIR)/etc/yum
-+YUMETC=$(DESTDIR)$(sysconfdir)/yum
-
- all:
- echo "Nothing to do"
-@@ -7,23 +7,23 @@
- rm -f *.pyc *.pyo *~
-
- install:
-- mkdir -p $(DESTDIR)/etc/yum/
-- mkdir -p $(DESTDIR)/etc/yum/repos.d
-+ mkdir -p $(DESTDIR)$(sysconfdir)/yum/
-+ mkdir -p $(DESTDIR)$(sysconfdir)/yum/repos.d
-
- install -m 644 yum.conf $(YUMETC)/yum.conf
-
- install -m 644 version-groups.conf $(YUMETC)/version-groups.conf
-
-- mkdir -p $(DESTDIR)/etc/logrotate.d
-- install -m 644 yum.logrotate $(DESTDIR)/etc/logrotate.d/yum
-+ mkdir -p $(DESTDIR)$(sysconfdir)/logrotate.d
-+ install -m 644 yum.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/yum
-
-- mkdir -p $(DESTDIR)/etc/rc.d/init.d
-- install -m 755 yum-updatesd.init $(DESTDIR)/etc/rc.d/init.d/yum-updatesd
-+ mkdir -p $(DESTDIR)$(sysconfdir)/rc.d/init.d
-+ install -m 755 yum-updatesd.init $(DESTDIR)$(sysconfdir)/rc.d/init.d/yum-updatesd
-
-- mkdir -p $(DESTDIR)/etc/dbus-1/system.d/
-- install -m 755 yum-updatesd-dbus.conf $(DESTDIR)/etc/dbus-1/system.d/yum-updatesd.conf
-+ mkdir -p $(DESTDIR)$(sysconfdir)/dbus-1/system.d/
-+ install -m 755 yum-updatesd-dbus.conf $(DESTDIR)$(sysconfdir)/dbus-1/system.d/yum-updatesd.conf
-
-- install -m 755 yum-updatesd.conf $(DESTDIR)/etc/yum/yum-updatesd.conf
-+ install -m 755 yum-updatesd.conf $(DESTDIR)$(sysconfdir)/yum/yum-updatesd.conf
-
-- mkdir -p $(DESTDIR)/etc/bash_completion.d
-- install -m 644 yum.bash $(DESTDIR)/etc/bash_completion.d
-+ mkdir -p $(DESTDIR)$(sysconfdir)/bash_completion.d
-+ install -m 644 yum.bash $(DESTDIR)$(sysconfdir)/bash_completion.d
diff --git a/meta/packages/yum/files/paths2.patch b/meta/packages/yum/files/paths2.patch
deleted file mode 100644
index 8fe6d0c983..0000000000
--- a/meta/packages/yum/files/paths2.patch
+++ /dev/null
@@ -1,35 +0,0 @@
----
- rpmUtils/Makefile | 2 +-
- yum/Makefile | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-Index: yum-3.2.27/rpmUtils/Makefile
-===================================================================
---- yum-3.2.27.orig/rpmUtils/Makefile 2010-03-24 17:26:39.759798777 +0000
-+++ yum-3.2.27/rpmUtils/Makefile 2010-03-24 17:26:54.835863845 +0000
-@@ -2,8 +2,8 @@
- PACKAGE = $(shell basename `pwd`)
- PYFILES = $(wildcard *.py)
- PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
--PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
--PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
-+PYSYSDIR = $(libdir)
-+PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
-
- all:
-Index: yum-3.2.27/yum/Makefile
-===================================================================
---- yum-3.2.27.orig/yum/Makefile 2010-03-24 17:26:39.759798777 +0000
-+++ yum-3.2.27/yum/Makefile 2010-03-24 17:26:43.726773783 +0000
-@@ -2,8 +2,8 @@
- PACKAGE = $(shell basename `pwd`)
- PYFILES = $(wildcard *.py)
- PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
--PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
--PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
-+PYSYSDIR = $(libdir)
-+PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
-
- all:
diff --git a/meta/packages/yum/files/yum-install-recommends.py b/meta/packages/yum/files/yum-install-recommends.py
deleted file mode 100755
index 64716f2c3e..0000000000
--- a/meta/packages/yum/files/yum-install-recommends.py
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/usr/bin/env python
-import os, sys
-
-root = sys.argv[1]
-installcmd = sys.argv[2]
-
-#
-# Take an rpm image and look through for Recommends:. For each recommends
-# found, try and install any matching packages including any Recommends for
-# packages installed by us.
-#
-
-
-def get_recommends():
- deps = []
- output = os.popen("rpm --root %s -aq --recommends" % (root))
- lines = output.readlines()
- for line in lines:
- line = line.replace("(none)","")
- if line:
- deps.append(line.split()[0])
- return deps
-
-processed = []
-
-while True:
- toinstall = []
- recommends = set(get_recommends())
- for item in recommends:
- if item not in processed:
- toinstall.append(item)
- if len(toinstall) != 0:
- print "Installing %s" % " ".join(toinstall)
- os.system("%s %s" % (installcmd, " ".join(toinstall)))
- else:
- break
- processed.extend(toinstall)
-
-
diff --git a/meta/packages/yum/yum_3.2.27.bb b/meta/packages/yum/yum_3.2.27.bb
deleted file mode 100644
index acebc79dde..0000000000
--- a/meta/packages/yum/yum_3.2.27.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-DESCRIPTION = "yum package manger is an automatic updater for rpm."
-HOMEPAGE = "http://yum.baseurl.org/"
-BUGTRACKER = "http://yum.baseurl.org/report"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
- file://yum/sqlutils.py;beginline=2;endline=14;md5=d704ae6a9d69ce90768ab9188236b992"
-
-RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \
- python-shell python-re python-logging python-pickle \
- python-netserver python-compression \
- python-unixadmin python-xml python-sqlite3 \
- python-textutils python-fcntl python-email \
- yum-metadata-parser"
-
-PR = "r9"
-
-SRC_URI = "http://yum.baseurl.org/download/3.2/yum-${PV}.tar.gz \
- file://paths.patch;apply=yes \
- file://paths2.patch;apply=yes \
- file://yum-install-recommends.py \
- file://extract-postinst.awk \
- file://98_yum"
-
-S = "${WORKDIR}/yum-${PV}"
-
-inherit autotools
-
-do_compile_append () {
- sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py
- sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py
-}
-
-do_install_append () {
- install -d ${D}${bindir}/
- install ${WORKDIR}/extract-postinst.awk ${D}${bindir}/
- install ${WORKDIR}/yum-install-recommends.py ${D}${bindir}/
- rmdir ${D}${localstatedir}/cache/yum
- rmdir ${D}${localstatedir}/cache
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/98_yum ${D}/etc/default/volatiles
-}
-
-FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli"
-
-BBCLASSEXTEND = "native"