aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/gtk+/gtk+-2.10.6/hardcoded_libtool.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gtk+/gtk+-2.10.6/hardcoded_libtool.patch')
-rw-r--r--meta/packages/gtk+/gtk+-2.10.6/hardcoded_libtool.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/gtk+/gtk+-2.10.6/hardcoded_libtool.patch b/meta/packages/gtk+/gtk+-2.10.6/hardcoded_libtool.patch
new file mode 100644
index 0000000000..bdbdb32f97
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.10.6/hardcoded_libtool.patch
@@ -0,0 +1,29 @@
+--- gtk+-2.10.0/configure.in.orig 2006-07-07 09:31:34.000000000 +0100
++++ gtk+-2.10.0/configure.in 2006-07-07 09:32:49.000000000 +0100
+@@ -370,7 +370,7 @@
+ AC_MSG_CHECKING([Whether to write dependencies into .pc files])
+ case $enable_explicit_deps in
+ auto)
+- deplibs_check_method=`(./libtool --config; echo eval echo \\$deplibs_check_method) | sh`
++ deplibs_check_method=`(./$host_alias-libtool --config; echo eval echo \\$deplibs_check_method) | sh`
+ if test "x$deplibs_check_method" '!=' xpass_all || test "x$enable_static" = xyes ; then
+ enable_explicit_deps=yes
+ else
+@@ -768,7 +768,7 @@
+ dnl Now we check to see if our libtool supports shared lib deps
+ dnl (in a rather ugly way even)
+ if $dynworks; then
+- pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
++ pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./$host_alias-libtool --config"
+ pixbuf_deplibs_check=`$pixbuf_libtool_config | \
+ grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
+ sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
+@@ -1600,7 +1600,7 @@
+ #
+ # We are using gmodule-no-export now, but I'm leaving the stripping
+ # code in place for now, since pango and atk still require gmodule.
+-export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++export_dynamic=`(./$host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ if test -n "$export_dynamic"; then
+ GDK_PIXBUF_DEP_LIBS=`echo $GDK_PIXBUF_DEP_LIBS | sed -e "s/$export_dynamic//"`
+ GDK_PIXBUF_XLIB_DEP_LIBS=`echo $GDK_PIXBUF_XLIB_DEP_LIBS | sed -e "s/$export_dynamic//"`