summaryrefslogtreecommitdiffstats
path: root/meta/classes/webos_component.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes/webos_component.bbclass')
-rw-r--r--meta/classes/webos_component.bbclass13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/classes/webos_component.bbclass b/meta/classes/webos_component.bbclass
new file mode 100644
index 0000000000..e29bdf46d9
--- /dev/null
+++ b/meta/classes/webos_component.bbclass
@@ -0,0 +1,13 @@
+# Copyright (c) 2012-2013 LG Electronics, Inc.
+#
+# webos_component
+#
+# This class is to be inherited by the recipe for every component developed by
+# Palm that has had any do_*() task code required for its standalone Ubuntu desktop
+# build to work moved to be in its CMakeLists/Makefile and is able to support
+# having the filesystem layout rooted at /opt/webos.
+#
+
+inherit webos_fs_layout
+
+WEBOS_SYSTEM_BUS_SKIP_DO_TASKS = "1"