aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps')
-rw-r--r--meta-demoapps/recipes-graphics/clutter/table.inc13
-rw-r--r--meta-demoapps/recipes-graphics/clutter/table/fixes.patch14
-rw-r--r--meta-demoapps/recipes-graphics/clutter/table_git.bb14
3 files changed, 41 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-graphics/clutter/table.inc b/meta-demoapps/recipes-graphics/clutter/table.inc
new file mode 100644
index 0000000000..937ad56b9c
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/table.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Table Clutter Demo"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPLv2.1 & GPLv2"
+
+DEPENDS = "clutter-gst-1.4 gnome-vfs"
+
+inherit autotools pkgconfig
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/table ${D}${bindir}/table
+}
+
diff --git a/meta-demoapps/recipes-graphics/clutter/table/fixes.patch b/meta-demoapps/recipes-graphics/clutter/table/fixes.patch
new file mode 100644
index 0000000000..a7cdc43713
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/table/fixes.patch
@@ -0,0 +1,14 @@
+Index: table/Makefile
+===================================================================
+--- table.orig/Makefile 2007-07-10 13:24:18.000000000 +0100
++++ table/Makefile 2007-07-10 13:28:10.000000000 +0100
+@@ -8,7 +8,7 @@ all: table
+
+
+ table: table.o clutter-dominatrix.o clutter-video-player.o
+- $(CC) -g -Wall $(CFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
++ $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
+
+ clean:
+ rm -fr *.o table
+\ No newline at end of file
diff --git a/meta-demoapps/recipes-graphics/clutter/table_git.bb b/meta-demoapps/recipes-graphics/clutter/table_git.bb
new file mode 100644
index 0000000000..5a5091cc1d
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/table_git.bb
@@ -0,0 +1,14 @@
+require table.inc
+
+LIC_FILES_CHKSUM = "file://fluttr/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://script-viewer/COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
+
+PV = "0.3.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.clutter-project.org/toys.git;protocol=git \
+ file://fixes.patch;patch=1"
+
+S = "${WORKDIR}/git/table"
+
+