aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-support/openobex/openobex_1.5.bb')
-rw-r--r--meta-demoapps/recipes-support/openobex/openobex_1.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-support/openobex/openobex_1.5.bb b/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
new file mode 100644
index 0000000000..dc07ae1353
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez4"
+LICENSE = "GPL"
+PR = "r4"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/bluetooth/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"