aboutsummaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-sato/kf/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-sato/kf/files')
-rw-r--r--meta-demoapps/recipes-sato/kf/files/fix-configure.patch25
-rw-r--r--meta-demoapps/recipes-sato/kf/files/fix-desktop-file.patch20
-rw-r--r--meta-demoapps/recipes-sato/kf/files/gcc4.patch30
3 files changed, 75 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-sato/kf/files/fix-configure.patch b/meta-demoapps/recipes-sato/kf/files/fix-configure.patch
new file mode 100644
index 0000000000..fc1ad9a418
--- /dev/null
+++ b/meta-demoapps/recipes-sato/kf/files/fix-configure.patch
@@ -0,0 +1,25 @@
+diff -urNd ../kf-0.5.4.1-r0/kf-0.5.4.1/configure.in kf-0.5.4.1/configure.in
+--- ../kf-0.5.4.1-r0/kf-0.5.4.1/configure.in 2005-04-27 19:42:49.000000000 +0100
++++ kf-0.5.4.1/configure.in 2005-09-29 14:12:32.000000000 +0100
+@@ -27,7 +27,7 @@
+ dnl AC_ARG_ENABLE(debug,)
+
+ dnl modules needed for package
+-MODULES="gtk+-2.0 >= 2.0.0 libglade-2.0 >= 1.110.0 loudmouth-1.0 >= 0.16"
++MODULES="gtk+-2.0 >= 2.0.0 libglade-2.0 >= 1.110.0 loudmouth-1.0 >= 0.16 libxml-2.0"
+ dnl MODULES="gtk+-2.0 >= 2.0.0 libglade-2.0 >= 1.110.0 loudmouth-1.0 >= 0.15.1"
+
+ dnl GtkSpell
+@@ -60,9 +60,9 @@
+ AC_DEFINE([HAVE_LM_CONNECTION_SET_JID],1,[We have lm_connection_set_jid])
+ fi
+
+-dnl XScreenSaver stuff...
+-AC_DEFINE([HAVE_XSCREENSAVER], [1], [Whether to support XScreenSaver extension])
+-PACKAGE_LIBS="$PACKAGE_LIBS -lXss -L/usr/X11R6/lib"
++#dnl XScreenSaver stuff...
++#AC_DEFINE([HAVE_XSCREENSAVER], [1], [Whether to support XScreenSaver extension])
++#PACKAGE_LIBS="$PACKAGE_LIBS -lXss -L/usr/X11R6/lib"
+
+ AC_SUBST(PACKAGE_CFLAGS)
+ AC_SUBST(PACKAGE_LIBS)
diff --git a/meta-demoapps/recipes-sato/kf/files/fix-desktop-file.patch b/meta-demoapps/recipes-sato/kf/files/fix-desktop-file.patch
new file mode 100644
index 0000000000..7a0f7d1bca
--- /dev/null
+++ b/meta-demoapps/recipes-sato/kf/files/fix-desktop-file.patch
@@ -0,0 +1,20 @@
+Common subdirectories: kf-0.5.4.1.orig/data and kf-0.5.4.1/data
+diff -u kf-0.5.4.1.orig/kf.desktop kf-0.5.4.1/kf.desktop
+--- kf-0.5.4.1.orig/kf.desktop 2005-04-19 22:08:44.000000000 +0100
++++ kf-0.5.4.1/kf.desktop 2005-10-03 14:36:47.000000000 +0100
+@@ -1,6 +1,6 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+-Name=kf jabber client
++Name=Instant Messenger
+ Name[pl]=kf klient sieci jabber
+ Name[lt]=Pokalbių programa kf
+ GenericName=Instant Messenger
+@@ -11,5 +11,6 @@
+ Icon=kf.png
+ Terminal=false
+ Type=Application
+-Categories=GTK;Application;Network;
++Categories=GTK;PIM;Application;Network;
+ StartupNotify=true
++X-MB-SingleInstance=true
diff --git a/meta-demoapps/recipes-sato/kf/files/gcc4.patch b/meta-demoapps/recipes-sato/kf/files/gcc4.patch
new file mode 100644
index 0000000000..58727ea0e0
--- /dev/null
+++ b/meta-demoapps/recipes-sato/kf/files/gcc4.patch
@@ -0,0 +1,30 @@
+Index: kf-0.5.4.1/src/jispman.c
+===================================================================
+--- kf-0.5.4.1.orig/src/jispman.c 2006-12-03 15:33:47.000000000 +0100
++++ kf-0.5.4.1/src/jispman.c 2006-12-03 15:35:01.000000000 +0100
+@@ -25,12 +25,6 @@
+ #include "emoticons.h"
+ #include "kf.h"
+
+-struct _KfJispManager {
+- GHashTable *jisps; /** A hash-table of all JISP pachages managed by this object, indexed by their filename */
+- GList *patterns; /** A list of patterns */
+-};
+-
+-
+ /**
+ * \brief create a new instance of KfJispManager
+ * \return a new instance of KfJispManager
+Index: kf-0.5.4.1/src/jispman.h
+===================================================================
+--- kf-0.5.4.1.orig/src/jispman.h 2006-12-03 15:33:47.000000000 +0100
++++ kf-0.5.4.1/src/jispman.h 2006-12-03 15:34:37.000000000 +0100
+@@ -25,6 +25,8 @@
+ #include "jisp.h"
+
+ typedef struct _KfJispManager {
++ GHashTable *jisps; /** A hash-table of all JISP pachages managed by this object, indexed by their filename */
++ GList *patterns; /** A list of patterns */
+ } KfJispManager;
+
+ /**