aboutsummaryrefslogtreecommitdiffstats
path: root/handbook/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'handbook/Makefile')
-rw-r--r--handbook/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
index 4a4dd7e83f..01353b11af 100644
--- a/handbook/Makefile
+++ b/handbook/Makefile
@@ -3,18 +3,20 @@ all: html pdf tarball
pdf:
./poky-doc-tools/poky-docbook-to-pdf poky-handbook.xml
+ ./poky-doc-tools/poky-docbook-to-pdf bsp-guide.xml
# -- old way --
# dblatex poky-handbook.xml
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel 1 \
+ --stringparam section.autolabel 1
+XSLTOPTS2 = --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl
+
html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc --stringparam html.stylesheet style.css \
- --stringparam chapter.autolabel 1 \
- --stringparam appendix.autolabel 1 \
- --stringparam section.autolabel 1 \
- -o poky-handbook.html \
- --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl \
- poky-handbook.xml
+ xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSLTOPTS2) poky-handbook.xml
+ xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSLTOPTS2) bsp-guide.xml
# -- old way --
# xmlto xhtml-nochunks poky-handbook.xml
@@ -24,7 +26,7 @@ tarball: html
validate:
xmllint --postvalid --xinclude --noout poky-handbook.xml
-OUTPUTS = poky-handbook.tgz poky-handbook.html poky-handbook.pdf
+OUTPUTS = poky-handbook.tgz poky-handbook.html poky-handbook.pdf bsp-guide.pdf
SOURCES = *.png *.xml *.css *.svg
publish: