aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/poky-ref-manual
diff options
context:
space:
mode:
Diffstat (limited to 'documentation/poky-ref-manual')
-rw-r--r--documentation/poky-ref-manual/bsp.xml6
-rw-r--r--documentation/poky-ref-manual/extendpoky.xml8
2 files changed, 7 insertions, 7 deletions
diff --git a/documentation/poky-ref-manual/bsp.xml b/documentation/poky-ref-manual/bsp.xml
index e0ca31732b..9982f9e739 100644
--- a/documentation/poky-ref-manual/bsp.xml
+++ b/documentation/poky-ref-manual/bsp.xml
@@ -105,8 +105,8 @@ meta-bsp/prebuilds/
# We have a conf directory, add to BBPATH
BBPATH := "${BBPATH}${LAYERDIR}"
-# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb"
+# We have a recipes directory containing .bb and .bbappend files, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes/*/*.bb ${LAYERDIR}/recipes/*/*.bbappend"
BBFILE_COLLECTIONS += "bsp"
BBFILE_PATTERN_bsp := "^${LAYERDIR}/"
@@ -115,7 +115,7 @@ BBFILE_PRIORITY_bsp = "5"
</para>
<para>
- which simply makes bitbake aware of the packages and conf directories.
+ which simply makes bitbake aware of the recipes and conf directories.
</para>
<para>
diff --git a/documentation/poky-ref-manual/extendpoky.xml b/documentation/poky-ref-manual/extendpoky.xml
index 57e085f403..aedd7c1c68 100644
--- a/documentation/poky-ref-manual/extendpoky.xml
+++ b/documentation/poky-ref-manual/extendpoky.xml
@@ -606,7 +606,7 @@ BBLAYERS = " \
<para>
Bitbake parses the conf/layer.conf of each of the layers in BBLAYERS
- to add the layers packages, classes and configuration to Poky.
+ to add the recipes, classes and configuration contained within the layer to Poky.
To create your own layer, independent of the main Poky repository,
you need only create a directory with a conf/layer.conf file and
add the directory to your bblayers.conf.
@@ -617,9 +617,9 @@ BBLAYERS = " \
<literallayout class='monospaced'># We have a conf and classes directory, add to BBPATH
BBPATH := "${BBPATH}:${LAYERDIR}"
-# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb \
- ${LAYERDIR}/packages/*/*.bbappend"
+# We have a recipes directory containing both .bb and .bbappend files, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes/*/*.bb \
+ ${LAYERDIR}/recipes/*/*.bbappend"
BBFILE_COLLECTIONS += "emenlow"
BBFILE_PATTERN_emenlow := "^${LAYERDIR}/"