aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake-dev/bin/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake-dev/bin/bitbake')
-rwxr-xr-xbitbake-dev/bin/bitbake3
1 files changed, 3 insertions, 0 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index f4cd0cb69a..d9aa910422 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -124,6 +124,9 @@ Default BBFILES are the .bb files in the current directory.""" )
parser.add_option( "-u", "--ui", help = "userinterface to use",
action = "store", dest = "ui")
+ parser.add_option( "", "--revisions-changed", help = "Set the exit code depending on whether upstream floating revisions have changed or not",
+ action = "store_true", dest = "revisions_changed", default = False )
+
options, args = parser.parse_args(sys.argv)
configuration = BBConfiguration(options)