summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb b/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb
index d4b1c1c454..c7897cdaf3 100644
--- a/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb
+++ b/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb
@@ -6,5 +6,10 @@ PROVIDES = "virtual/libgl virtual/mesa"
S = "${WORKDIR}/mesa-${PV}"
-PACKAGECONFIG ??= "opengl dri ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
-PACKAGECONFIG_class-target = "opengl dri ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
+# At least one DRI rendering engine is required to build mesa.
+# When no X11 is available, use osmesa for the rendering engine.
+PACKAGECONFIG ??= "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa', d)}"
+PACKAGECONFIG_class-target = "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa', d)}"
+
+# When NOT using X11, we need to make sure we have swrast available.
+DRIDRIVERS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', ',swrast', d)}"