summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-sato/webkit/libwpe_1.4.0.1.bb4
-rw-r--r--meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb b/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb
index 346ca9b1d8..12499ff281 100644
--- a/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb
+++ b/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb
@@ -9,7 +9,9 @@ DEPENDS = "virtual/egl libxkbcommon"
# Workaround build issue with RPi userland EGL libraries.
CFLAGS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"
-inherit cmake
+inherit cmake features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "09849dfb34877354f34f318e138971cf22e677b2179e1f0a8ea00ab0b7bd8e9b"
diff --git a/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb b/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
index 7db5806d9d..cd2f7fabda 100644
--- a/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
+++ b/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
@@ -8,7 +8,9 @@ DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe"
DEPENDS_append_class-target = " wayland-native"
-inherit cmake
+inherit cmake features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "6249a0b7cbfa662206a8d2fa24e2c574e75c681ad0e93468091f1dc68ddb299d"