aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/libxcrypt/files/0001-Add-x32-specific-inline-asm.patch42
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt.bb (renamed from meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb)8
2 files changed, 4 insertions, 46 deletions
diff --git a/meta/recipes-core/libxcrypt/files/0001-Add-x32-specific-inline-asm.patch b/meta/recipes-core/libxcrypt/files/0001-Add-x32-specific-inline-asm.patch
deleted file mode 100644
index 9e31b03561..0000000000
--- a/meta/recipes-core/libxcrypt/files/0001-Add-x32-specific-inline-asm.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 7d01f2acf6fde6341a68a91f9b343841cc424af7 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 17 Dec 2018 11:33:35 -0800
-Subject: [PATCH] Add x32 specific inline asm
-
-Upstream-Status: Pending [https://github.com/besser82/libxcrypt/issues/74#issuecomment-447966455]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- alg-yescrypt-opt.c | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/alg-yescrypt-opt.c b/alg-yescrypt-opt.c
-index 5dbd822..060caf4 100644
---- a/alg-yescrypt-opt.c
-+++ b/alg-yescrypt-opt.c
-@@ -528,6 +528,11 @@ static volatile uint64_t Smask2var = Smask2;
- #undef MAYBE_MEMORY_BARRIER
- #define MAYBE_MEMORY_BARRIER \
- __asm__("" : : : "memory");
-+#ifdef __ILP32__ /* x32 */
-+#define REGISTER_PREFIX "e"
-+#else
-+#define REGISTER_PREFIX "r"
-+#endif
- #define PWXFORM_SIMD(X) { \
- __m128i H; \
- __asm__( \
-@@ -537,8 +542,8 @@ static volatile uint64_t Smask2var = Smask2;
- "pmuludq %1, %0\n\t" \
- "movl %%eax, %%ecx\n\t" \
- "shrq $0x20, %%rax\n\t" \
-- "paddq (%3,%%rcx), %0\n\t" \
-- "pxor (%4,%%rax), %0\n\t" \
-+ "paddq (%3,%%" REGISTER_PREFIX "cx), %0\n\t" \
-+ "pxor (%4,%%" REGISTER_PREFIX "ax), %0\n\t" \
- : "+x" (X), "=x" (H) \
- : "d" (Smask2), "S" (S0), "D" (S1) \
- : "cc", "ax", "cx"); \
---
-2.20.1
-
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb b/meta/recipes-core/libxcrypt/libxcrypt.bb
index 594203a59c..3b9af6d739 100644
--- a/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
+++ b/meta/recipes-core/libxcrypt/libxcrypt.bb
@@ -3,18 +3,18 @@ DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
HOMEPAGE = "https://github.com/besser82/libxcrypt"
SECTION = "libs"
LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM ?= "file://LICENSING;md5=e28ba6195a4e39904919b78a92bcf27e \
+LIC_FILES_CHKSUM ?= "file://LICENSING;md5=be275bc7f91642efe7709a8ae7a1433b \
file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
"
inherit autotools pkgconfig
-# v4.4.1
-SRCREV ?= "b8714d4e9e37cf0d511917bd5eea0e51e4a397d5"
+PV = "4.4.2"
+# v4.4.2
+SRCREV ?= "cf6abf18083566ec1612af27982a5160c9e0f137"
SRCBRANCH ?= "develop"
SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
- file://0001-Add-x32-specific-inline-asm.patch \
"
PROVIDES = "virtual/crypt"