aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/x11-common/x11-common/Xserver.in (renamed from meta/recipes-graphics/x11-common/x11-common/etc/X11/Xserver)2
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb9
2 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xserver b/meta/recipes-graphics/x11-common/x11-common/Xserver.in
index 73570dfeb5..b8eed7610f 100644
--- a/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xserver
+++ b/meta/recipes-graphics/x11-common/x11-common/Xserver.in
@@ -5,7 +5,7 @@ XSERVER=/usr/bin/Xorg
. /etc/profile
-ARGS=" -br -pn"
+ARGS=" -br -pn @BLANK_ARGS@"
DISPLAY=':0'
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
index 156b329486..6d7c347c00 100644
--- a/meta/recipes-graphics/x11-common/x11-common_0.1.bb
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -9,14 +9,21 @@ inherit distro_features_check
REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI = "file://etc \
+ file://Xserver.in \
file://gplv2-license.patch"
S = "${WORKDIR}"
+PACKAGECONFIG ??= "blank"
+# dpms and screen saver will be on only if 'blank' is in PACKAGECONFIG
+PACKAGECONFIG[blank] = ""
+
do_install() {
cp -R ${S}/etc ${D}${sysconfdir}
+ sed -e 's/@BLANK_ARGS@/${@bb.utils.contains('PACKAGECONFIG', 'blank', '', '-s 0 -dpms', d)}/' \
+ ${S}/Xserver.in > ${D}${sysconfdir}/X11/Xserver
+
chmod -R 755 ${D}${sysconfdir}
- find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
}
RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"