summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_3.32.3.bb (renamed from meta/recipes-gnome/epiphany/epiphany_3.32.2.bb)5
-rw-r--r--meta/recipes-gnome/epiphany/files/0001-web-app-utils-Clean-up-ephy_web_application_create.patch79
2 files changed, 2 insertions, 82 deletions
diff --git a/meta/recipes-gnome/epiphany/epiphany_3.32.2.bb b/meta/recipes-gnome/epiphany/epiphany_3.32.3.bb
index ff0e34f98d..de1b6e2f84 100644
--- a/meta/recipes-gnome/epiphany/epiphany_3.32.2.bb
+++ b/meta/recipes-gnome/epiphany/epiphany_3.32.3.bb
@@ -12,10 +12,9 @@ REQUIRED_DISTRO_FEATURES = "x11 opengl"
SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
file://0002-help-meson.build-disable-the-use-of-yelp.patch \
- file://0001-web-app-utils-Clean-up-ephy_web_application_create.patch \
"
-SRC_URI[archive.md5sum] = "2a6672b22a0fdb869e5f0a415ac2da34"
-SRC_URI[archive.sha256sum] = "8ae70d9feaba3754c63ab249deeef9b7a31161a372655b4214f148ea2f440cfa"
+SRC_URI[archive.md5sum] = "c4976507bf3de69f27a050ad09531f5a"
+SRC_URI[archive.sha256sum] = "3ccb6859a43b839b714aa425cb185056f1e8604adbaab6a1bc179d1ba641a33f"
FILES_${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
RDEPENDS_${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"
diff --git a/meta/recipes-gnome/epiphany/files/0001-web-app-utils-Clean-up-ephy_web_application_create.patch b/meta/recipes-gnome/epiphany/files/0001-web-app-utils-Clean-up-ephy_web_application_create.patch
deleted file mode 100644
index ea644fb985..0000000000
--- a/meta/recipes-gnome/epiphany/files/0001-web-app-utils-Clean-up-ephy_web_application_create.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From 49f435217873e679b142f64d3e7def919fb642bb Mon Sep 17 00:00:00 2001
-From: Michael Catanzaro <mcatanzaro@igalia.com>
-Date: Wed, 8 May 2019 15:58:32 +0000
-Subject: [PATCH] web-app-utils: Clean up ephy_web_application_create()
-
-Fixes #764
-
-(cherry picked from commit 4e998d45e4cc549a7ca561a33895b0fbcf7ba6bb)
-Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/epiphany/commit/a6a022c9c498ad5dcf7f2220644a7520df74ca31]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- lib/ephy-web-app-utils.c | 24 ++++++++++--------------
- 1 file changed, 10 insertions(+), 14 deletions(-)
-
-diff --git a/lib/ephy-web-app-utils.c b/lib/ephy-web-app-utils.c
-index 97f3f24..fc68a96 100644
---- a/lib/ephy-web-app-utils.c
-+++ b/lib/ephy-web-app-utils.c
-@@ -374,46 +374,42 @@ ephy_web_application_create (const char *id,
- const char *name,
- GdkPixbuf *icon)
- {
-- char *profile_dir;
-- char *desktop_file_path = NULL;
-+ g_autofree char *app_file = NULL;
-+ g_autofree char *profile_dir = NULL;
-+ g_autofree char *desktop_file_path = NULL;
-
- /* If there's already a WebApp profile for the contents of this
- * view, do nothing. */
- profile_dir = ephy_web_application_get_profile_directory (id);
- if (g_file_test (profile_dir, G_FILE_TEST_IS_DIR)) {
- g_warning ("Profile directory %s already exists", profile_dir);
-- goto out;
-+ return NULL;
- }
-
- /* Create the profile directory, populate it. */
- if (g_mkdir_with_parents (profile_dir, 488) == -1) {
- g_warning ("Failed to create directory %s", profile_dir);
-- goto out;
-+ return NULL;
- }
-
- /* Skip migration for new web apps. */
- ephy_profile_utils_set_migration_version_for_profile_dir (EPHY_PROFILE_MIGRATION_VERSION, profile_dir);
-
- /* Create an .app file. */
-- g_autofree char *app_file = g_build_filename (profile_dir, ".app", NULL);
-+ app_file = g_build_filename (profile_dir, ".app", NULL);
- int fd = g_open (app_file, O_WRONLY|O_CREAT|O_TRUNC, 0644);
- if (fd < 0) {
-- LOG ("Failed to create .app file: %s", g_strerror (errno));
-- goto out;
-- } else {
-- close (fd);
-+ g_warning ("Failed to create .app file: %s", g_strerror (errno));
-+ return NULL;
- }
-+ close (fd);
-
- /* Create the deskop file. */
- desktop_file_path = create_desktop_file (id, name, address, profile_dir, icon);
- if (desktop_file_path)
- ephy_web_application_initialize_settings (profile_dir);
-
-- out:
-- if (profile_dir)
-- g_free (profile_dir);
--
-- return desktop_file_path;
-+ return g_steal_pointer (&desktop_file_path);
- }
-
- char *
---
-2.21.0
-