aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/classes/systemd.bbclass4
-rw-r--r--meta/recipes-core/systemd/systemd_208.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/systemd.bbclass b/meta/classes/systemd.bbclass
index 3700b2eee3..7a8d35cd2f 100644
--- a/meta/classes/systemd.bbclass
+++ b/meta/classes/systemd.bbclass
@@ -9,8 +9,8 @@ SYSTEMD_PACKAGES_class-nativesdk ?= ""
SYSTEMD_AUTO_ENABLE ??= "enable"
# This class will be included in any recipe that supports systemd init scripts,
-# even if the systemd DISTRO_FEATURE isn't enabled. As such don't make any
-# changes directly but check the DISTRO_FEATURES first.
+# even if systemd is not in DISTRO_FEATURES. As such don't make any changes
+# directly but check the DISTRO_FEATURES first.
python __anonymous() {
features = d.getVar("DISTRO_FEATURES", True).split()
# If the distro features have systemd but not sysvinit, inhibit update-rcd
diff --git a/meta/recipes-core/systemd/systemd_208.bb b/meta/recipes-core/systemd/systemd_208.bb
index ee716f43e1..8c70fe507c 100644
--- a/meta/recipes-core/systemd/systemd_208.bb
+++ b/meta/recipes-core/systemd/systemd_208.bb
@@ -323,8 +323,8 @@ pkg_prerm_udev-hwdb () {
rm -f ${sysconfdir}/udev/hwdb.bin
}
-# As this recipe builds udev, respect the systemd DISTRO_FEATURE so we don't try
-# building udev and systemd in world builds.
+# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
+# that we don't build both udev and systemd in world builds.
python () {
if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")