aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb5
-rw-r--r--meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb3
-rw-r--r--meta/recipes-tbd/meta/meta-ide-support.bb2
-rwxr-xr-xscripts/poky-export-rootfs2
-rwxr-xr-xscripts/poky-find-native-sysroot2
-rwxr-xr-xscripts/poky-qemu-ifdown2
-rwxr-xr-xscripts/poky-qemu-ifup2
7 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
index 473411db92..791465694b 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
@@ -1,19 +1,19 @@
DESCRIPTION = "Qemu helper scripts from Poky"
LICENSE = "GPL"
RDEPENDS = "qemu-nativesdk"
-PR = "r7"
+PR = "r8"
FILESPATH = "${FILE_DIRNAME}/qemu-helper"
SRC_URI = "file://${POKYBASE}/scripts/poky-qemu \
file://${POKYBASE}/scripts/poky-qemu-internal \
file://${POKYBASE}/scripts/poky-addptable2image \
+ file://${POKYBASE}/scripts/poky-gen-tapdevs \
file://${POKYBASE}/scripts/poky-qemu-ifup \
file://${POKYBASE}/scripts/poky-qemu-ifdown \
file://${POKYBASE}/scripts/poky-find-native-sysroot \
file://${POKYBASE}/scripts/poky-extract-sdk \
file://${POKYBASE}/scripts/poky-export-rootfs \
- file://${POKYBASE}/scripts/runqemu-nfs \
file://tunctl.c \
file://raw2flash.c \
"
@@ -31,7 +31,6 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}${POKYBASE}/scripts/poky-* ${D}${bindir}/
- install -m 0755 ${WORKDIR}${POKYBASE}/scripts/runqemu-nfs ${D}${bindir}/
install tunctl ${D}${bindir}/
install raw2flash.spitz ${D}${bindir}/
install flash2raw.spitz ${D}${bindir}/
diff --git a/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb b/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
index ecba4525a2..66012189dc 100644
--- a/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
+++ b/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
@@ -3,7 +3,8 @@ SECTION = "console/network"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-PR = "r0"
+RDEPENDS = "pseudo"
+PR = "r1"
SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${PV}.tar.gz \
file://001-2.2b47-2.2b51.patch \
diff --git a/meta/recipes-tbd/meta/meta-ide-support.bb b/meta/recipes-tbd/meta/meta-ide-support.bb
index 70a0c64aba..8fe9a23036 100644
--- a/meta/recipes-tbd/meta/meta-ide-support.bb
+++ b/meta/recipes-tbd/meta/meta-ide-support.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
LICENSE = "MIT"
-DEPENDS = "virtual/libc gdb-cross"
+DEPENDS = "virtual/libc gdb-cross qemu-helper-native unfs-server-native"
PR = "r1"
inherit meta toolchain-scripts
diff --git a/scripts/poky-export-rootfs b/scripts/poky-export-rootfs
index f3552516ad..3ab0597c9a 100755
--- a/scripts/poky-export-rootfs
+++ b/scripts/poky-export-rootfs
@@ -50,7 +50,7 @@ if [ ! -e "$POKY_NATIVE_SYSROOT/usr/sbin/rpc.mountd" ]; then
echo "Error: Unable to find rpc.mountd binary in $POKY_NATIVE_SYSROOT/usr/sbin/"
if [ "x$POKY_DISTRO_VERSION" = "x" ]; then
- echo "Have you run 'bitbake unfs-server-native'?"
+ echo "Have you run 'bitbake meta-ide-support'?"
else
echo "This shouldn't happen - something is missing from your toolchain installation"
fi
diff --git a/scripts/poky-find-native-sysroot b/scripts/poky-find-native-sysroot
index 9182f9d170..d8002f963e 100755
--- a/scripts/poky-find-native-sysroot
+++ b/scripts/poky-find-native-sysroot
@@ -60,7 +60,7 @@ if [ ! -e "$POKY_NATIVE_SYSROOT/usr/bin/pseudo" ]; then
echo "Error: Unable to find pseudo binary in $POKY_NATIVE_SYSROOT/usr/bin/"
if [ "x$POKY_DISTRO_VERSION" = "x" ]; then
- echo "Have you run 'bitbake pseudo-native'?"
+ echo "Have you run 'bitbake meta-ide-support'?"
else
echo "This shouldn't happen - something is wrong with your toolchain installation"
fi
diff --git a/scripts/poky-qemu-ifdown b/scripts/poky-qemu-ifdown
index ece2dc998a..60ca919dea 100755
--- a/scripts/poky-qemu-ifdown
+++ b/scripts/poky-qemu-ifdown
@@ -50,7 +50,7 @@ if [ ! -e "$TUNCTL" ]; then
if [[ "$NATIVE_SYSROOT_DIR" =~ ^\/opt\/poky ]]; then
echo "This shouldn't happen - something is wrong with your toolchain installation"
else
- echo "Have you run 'bitbake qemu-helper-native'?"
+ echo "Have you run 'bitbake meta-ide-support'?"
fi
exit 1
diff --git a/scripts/poky-qemu-ifup b/scripts/poky-qemu-ifup
index cd4c47b608..8685c83cce 100755
--- a/scripts/poky-qemu-ifup
+++ b/scripts/poky-qemu-ifup
@@ -57,7 +57,7 @@ if [ ! -x "$TUNCTL" ]; then
if [[ "$NATIVE_SYSROOT_DIR" =~ ^\/opt\/poky ]]; then
echo "This shouldn't happen - something is wrong with your toolchain installation"
else
- echo "Have you run 'bitbake qemu-helper-native'?"
+ echo "Have you run 'bitbake meta-ide-support'?"
fi
exit 1