aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/tinylogin/tinylogin-1.4/avoid_static.patch33
-rw-r--r--meta/recipes-core/tinylogin/tinylogin_1.4.bb7
2 files changed, 37 insertions, 3 deletions
diff --git a/meta/recipes-core/tinylogin/tinylogin-1.4/avoid_static.patch b/meta/recipes-core/tinylogin/tinylogin-1.4/avoid_static.patch
new file mode 100644
index 0000000000..8a06af0ddf
--- /dev/null
+++ b/meta/recipes-core/tinylogin/tinylogin-1.4/avoid_static.patch
@@ -0,0 +1,33 @@
+tinylogin: Do not link statically when building debug
+
+For some reason if DODEBUG was enabled (to prevent stripping) the binary was
+also statically linked. This patch prevents that behavior.
+
+Upstream-Status: Inappropriate [no upstream]
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur tinylogin-1.4.orig/Makefile tinylogin-1.4/Makefile
+--- tinylogin-1.4.orig/Makefile 2011-06-18 11:00:23.073927349 -0500
++++ tinylogin-1.4/Makefile 2011-06-18 11:03:26.394849372 -0500
+@@ -123,20 +123,6 @@
+ LDFLAGS += -s -Wl,-warn-common
+ STRIP = $(STRIPTOOL) --remove-section=.note --remove-section=.comment $(PROG)
+ endif
+-ifeq ($(strip $(DODEBUG)),true)
+- LDFLAGS += --static
+- #
+- #use '-ffunction-sections -fdata-sections' and '--gc-sections' (if they
+- # work) to try and strip out any unused junk. Doesn't do much for me,
+- # but you may want to give it a shot...
+- #
+- #ifeq ($(shell $(CC) -ffunction-sections -fdata-sections -S \
+- # -o /dev/null -xc /dev/null 2>/dev/null && $(LD) \
+- # --gc-sections -v >/dev/null && echo 1),1)
+- # CFLAGS += -ffunction-sections -fdata-sections
+- # LDFLAGS += --gc-sections
+- #endif
+-endif
+ ifeq ($(strip $(DOSTATIC)),true)
+ LDFLAGS += --static
+ #
diff --git a/meta/recipes-core/tinylogin/tinylogin_1.4.bb b/meta/recipes-core/tinylogin/tinylogin_1.4.bb
index 0b51b25853..b620d45924 100644
--- a/meta/recipes-core/tinylogin/tinylogin_1.4.bb
+++ b/meta/recipes-core/tinylogin/tinylogin_1.4.bb
@@ -7,7 +7,7 @@ and groups on an embedded system."
HOMEPAGE = "http://tinylogin.busybox.net/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM="file://LICENSE;md5=f1060fa3a366f098b5b1d8c2077ba269"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
file://cvs-20040608.patch;patch=1;pnum=1 \
@@ -15,7 +15,8 @@ SRC_URI = "http://tinylogin.busybox.net/downloads/tinylogin-${PV}.tar.bz2 \
file://adduser-empty_pwd.patch;patch=1 \
file://remove-index.patch;patch=1 \
file://use_O2_option.patch \
- file://passwd_rotate_check.patch"
+ file://passwd_rotate_check.patch \
+ file://avoid_static.patch"
SRC_URI[md5sum] = "44da0ff2b727455669890b24305e351d"
SRC_URI[sha256sum] = "5e542e4b7825305a3678bf73136c392feb0d44b8bbf926e8eda5453eea7ddd6b"
@@ -23,7 +24,7 @@ SRC_URI[sha256sum] = "5e542e4b7825305a3678bf73136c392feb0d44b8bbf926e8eda5453eea
EXTRA_OEMAKE = ""
do_compile () {
- oe_runmake 'CC=${CC}' 'CROSS=${HOST_PREFIX}'
+ oe_runmake 'CC=${CC}' 'CROSS=${HOST_PREFIX}' 'DODEBUG=true'
}
do_install () {