aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
index a93acc9ee3..abc25db9cc 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
PRIORITY = "optional"
-PR = "r24"
+PR = "r25"
RDEPENDS_${PN} = "dbus-wait sudo"
SRC_URI = "file://xserver-nodm \
@@ -30,12 +30,13 @@ pkg_postinst_${PN} () {
fi
if [ -f /etc/X11/Xusername ]; then
- # create the rootless X user, and add user to group tty, video
+ # create the rootless X user, and add user to group tty, video, audio
username=`cat /etc/X11/Xusername`
adduser --disabled-password $username
# FIXME: use addgroup if busybox addgroup is ready
sed -i -e "s/^video:.*/&${username}/g" /etc/group
sed -i -e "s/^tty:.*/&${username}/g" /etc/group
+ sed -i -e "s/^audio:.*/&${username}/g" /etc/group
fi
}