aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/images/core-image-core.bb2
-rw-r--r--meta/recipes-core/images/core-image-minimal-dev.bb3
-rw-r--r--meta/recipes-core/images/core-image-minimal-initramfs.bb6
-rw-r--r--meta/recipes-core/images/core-image-minimal-mtdutils.bb6
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb1
-rw-r--r--meta/recipes-extended/images/core-image-lsb-dev.bb6
-rw-r--r--meta/recipes-extended/images/core-image-lsb-sdk.bb6
-rw-r--r--meta/recipes-extended/images/core-image-lsb.bb3
-rw-r--r--meta/recipes-qt/images/qt4e-demo-image.bb1
-rw-r--r--meta/recipes-rt/images/core-image-rt-sdk.bb4
-rw-r--r--meta/recipes-rt/images/core-image-rt.bb3
-rw-r--r--meta/recipes-sato/images/core-image-sato-dev.bb6
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk.bb6
-rw-r--r--meta/recipes-sato/images/core-image-sato.bb5
14 files changed, 33 insertions, 25 deletions
diff --git a/meta/recipes-core/images/core-image-core.bb b/meta/recipes-core/images/core-image-core.bb
index 2d768e0b78..ae32be8b48 100644
--- a/meta/recipes-core/images/core-image-core.bb
+++ b/meta/recipes-core/images/core-image-core.bb
@@ -1,7 +1,7 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "An X11 image with simple applications such as terminal, editor \
+DESCRIPTION = "An X11 image with simple applications such as terminal, editor, \
and file manager."
IMAGE_FEATURES += "apps-console-core ${X11_IMAGE_FEATURES}"
diff --git a/meta/recipes-core/images/core-image-minimal-dev.bb b/meta/recipes-core/images/core-image-minimal-dev.bb
index 3a0a1879ec..67c7790f00 100644
--- a/meta/recipes-core/images/core-image-minimal-dev.bb
+++ b/meta/recipes-core/images/core-image-minimal-dev.bb
@@ -1,7 +1,8 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "A core-image-minimal image suitable for development work."
+DESCRIPTION = "A small image just capable of allowing a device to boot and \
+is suitable for development work."
IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE}"
diff --git a/meta/recipes-core/images/core-image-minimal-initramfs.bb b/meta/recipes-core/images/core-image-minimal-initramfs.bb
index 85b9ff9b3f..4aeb6188f7 100644
--- a/meta/recipes-core/images/core-image-minimal-initramfs.bb
+++ b/meta/recipes-core/images/core-image-minimal-initramfs.bb
@@ -1,7 +1,7 @@
# Simple initramfs image. Mostly used for live images.
-DESCRIPTION = "A core-image-minimal image that has the Minimal RAM-based \
-Initial Root Filesystem (initramfs) as part of the kernel, which allows the \
-system to find the first 'init' program more efficiently."
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
+first “init” program more efficiently."
IMAGE_INSTALL = "initramfs-live-boot initramfs-live-install busybox udev base-passwd"
diff --git a/meta/recipes-core/images/core-image-minimal-mtdutils.bb b/meta/recipes-core/images/core-image-minimal-mtdutils.bb
index df2fab1f2c..331f16ca97 100644
--- a/meta/recipes-core/images/core-image-minimal-mtdutils.bb
+++ b/meta/recipes-core/images/core-image-minimal-mtdutils.bb
@@ -3,8 +3,8 @@
#
require core-image-minimal.bb
-DESCRIPTION = "A core-image-minimal image that supports the Minimal MTD \
-Utilities, which let the user interact with the MTD subsystem in the kernel \
-to perform operations on flash devices."
+DESCRIPTION = "Small image capable of booting a device with support for the \
+Minimal MTD Utilities, which let the user interact with the MTD subsystem in \
+the kernel to perform operations on flash devices."
IMAGE_INSTALL += "mtd-utils"
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index 1db6a7a3b2..cf3ef5fd24 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -1,3 +1,4 @@
+DESCRIPTION = "Version 1.0-r6 of the self-hosted image."
IMAGE_INSTALL = "task-core-boot task-core-apps-console task-core-ssh-openssh task-self-hosted"
LICENSE = "MIT"
diff --git a/meta/recipes-extended/images/core-image-lsb-dev.bb b/meta/recipes-extended/images/core-image-lsb-dev.bb
index e6d7bc9d47..3bb78003af 100644
--- a/meta/recipes-extended/images/core-image-lsb-dev.bb
+++ b/meta/recipes-extended/images/core-image-lsb-dev.bb
@@ -1,6 +1,6 @@
-DESCRIPTION = "A core-image-lsb that includes everything in meta-toolchain \
-but also includes development headers and libraries to form a complete \
-standalone SDK."
+DESCRIPTION = "Basic image without X support suitable for development work. It \
+can be used for customization and implementations that conform to Linux \
+Standard Base (LSB)."
IMAGE_FEATURES += "apps-console-core dev-pkgs ssh-server-openssh"
diff --git a/meta/recipes-extended/images/core-image-lsb-sdk.bb b/meta/recipes-extended/images/core-image-lsb-sdk.bb
index 08928913f0..32a5077e38 100644
--- a/meta/recipes-extended/images/core-image-lsb-sdk.bb
+++ b/meta/recipes-extended/images/core-image-lsb-sdk.bb
@@ -1,6 +1,6 @@
-DESCRIPTION = "A core-image-lsb that includes everything in meta-toolchain \
-but also includes development headers and libraries to form a complete \
-standalone SDK."
+DESCRIPTION = "Basic image without X support suitable for Linux Standard Base \
+(LSB) implementations. It includes the full meta-toolchain, plus development \
+headers and libraries to form a standalone SDK."
IMAGE_FEATURES += "apps-console-core tools-sdk dev-pkgs ssh-server-openssh"
EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
diff --git a/meta/recipes-extended/images/core-image-lsb.bb b/meta/recipes-extended/images/core-image-lsb.bb
index b0a3a4dfa0..b370d49c58 100644
--- a/meta/recipes-extended/images/core-image-lsb.bb
+++ b/meta/recipes-extended/images/core-image-lsb.bb
@@ -1,4 +1,5 @@
-DESCRIPTION = "A core-image-basic image suitable for implementations that \
+DESCRIPTION = "A foundational basic image without support for X that can be \
+reasonably used for customization and is suitable for implementations that \
conform to Linux Standard Base (LSB)."
IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
diff --git a/meta/recipes-qt/images/qt4e-demo-image.bb b/meta/recipes-qt/images/qt4e-demo-image.bb
index 2e50bf6029..6c0dc70853 100644
--- a/meta/recipes-qt/images/qt4e-demo-image.bb
+++ b/meta/recipes-qt/images/qt4e-demo-image.bb
@@ -1,3 +1,4 @@
+DESCRIPTION = "Version 1.0-r1 of the qtr3-demo-image."
LICENSE = "MIT"
PR="r1"
diff --git a/meta/recipes-rt/images/core-image-rt-sdk.bb b/meta/recipes-rt/images/core-image-rt-sdk.bb
index 6e983433aa..5a67eebbce 100644
--- a/meta/recipes-rt/images/core-image-rt-sdk.bb
+++ b/meta/recipes-rt/images/core-image-rt-sdk.bb
@@ -2,7 +2,9 @@
# Copyright (C) 2011 Intel Corporation.
#
-DESCRIPTION = "Real-Time Linux Image with SDK support"
+DESCRIPTION = "Small image capable of booting a device with a test suite and \
+tools for real-time use. It includes the full meta-toolchain, development \
+headers and libraries to form a standalone SDK."
DEPENDS = "linux-yocto-rt"
require recipes-core/images/core-image-minimal.bb
diff --git a/meta/recipes-rt/images/core-image-rt.bb b/meta/recipes-rt/images/core-image-rt.bb
index e11f159f7a..ef547a64af 100644
--- a/meta/recipes-rt/images/core-image-rt.bb
+++ b/meta/recipes-rt/images/core-image-rt.bb
@@ -2,7 +2,8 @@
# Copyright (C) 2010 Intel Corporation.
#
-DESCRIPTION = "Real-Time Linux Image"
+DESCRIPTION = "A small image just capable of allowing a device to boot plus a \
+real-time test suite and tools appropriate for real-time use."
DEPENDS = "linux-yocto-rt"
require recipes-core/images/core-image-minimal.bb
diff --git a/meta/recipes-sato/images/core-image-sato-dev.bb b/meta/recipes-sato/images/core-image-sato-dev.bb
index b30447c583..bd3172782e 100644
--- a/meta/recipes-sato/images/core-image-sato-dev.bb
+++ b/meta/recipes-sato/images/core-image-sato-dev.bb
@@ -1,9 +1,9 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "A core-image-sato image suitable for development that also \
-includes a native toolchain and libraries needed to build applications on the \
-device itself."
+DESCRIPTION = "Image with Sato for development work. It includes everything \
+within core-image-sato plus a native toolchain, application development and \
+testing libraries, profiling and debug symbols."
IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs"
diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index 2cf8cadea7..6dfd470f66 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -1,9 +1,9 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "A core-image-sato image that includes everything in \
-meta-toolchain. The image also includes development headers and libraries \
-to form a complete standalone SDK."
+DESCRIPTION = "Image with Sato support that includes everything within \
+core-image-sato plus meta-toolchain, development headers and libraries to \
+form a standalone SD."
IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs tools-sdk qt4-pkgs"
EXTRA_IMAGE_FEATURES += "tools-debug tools-profile tools-testapps debug-tweaks"
diff --git a/meta/recipes-sato/images/core-image-sato.bb b/meta/recipes-sato/images/core-image-sato.bb
index 11c3318001..b6c51fb405 100644
--- a/meta/recipes-sato/images/core-image-sato.bb
+++ b/meta/recipes-sato/images/core-image-sato.bb
@@ -1,8 +1,9 @@
#
# Copyright (C) 2007 OpenedHand Ltd.
#
-DESCRIPTION = "An image with Sato support, a mobile environment and visual \
-style that works well with mobile devices."
+DESCRIPTION = "Image with Sato, a mobile environment and visual style for \
+mobile devices. The image supports X11 with a Sato theme, Pimlico \
+applications, and contains terminal, editor, and file manager."
IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES}"