aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/busybox/busybox.inc4
-rw-r--r--meta/recipes-core/busybox/busybox_1.18.4.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index 1334d06964..c51cf6a124 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -47,8 +47,8 @@ def busybox_cfg(feature, features, tokens, cnf, rem):
# Map distro and machine features to config settings
def features_to_busybox_settings(d):
cnf, rem = ([], [])
- distro_features = bb.data.getVar('DISTRO_FEATURES', d).split()
- machine_features = bb.data.getVar('MACHINE_FEATURES', d).split()
+ distro_features = bb.data.getVar('DISTRO_FEATURES', d, True).split()
+ machine_features = bb.data.getVar('MACHINE_FEATURES', d, True).split()
busybox_cfg('ipv6', distro_features, 'CONFIG_FEATURE_IPV6', cnf, rem)
busybox_cfg('largefile', distro_features, 'CONFIG_LFS', cnf, rem)
busybox_cfg('largefile', distro_features, 'CONFIG_FDISK_SUPPORT_LARGE_DISKS', cnf, rem)
diff --git a/meta/recipes-core/busybox/busybox_1.18.4.bb b/meta/recipes-core/busybox/busybox_1.18.4.bb
index 5883cc65cf..9d3d5b138e 100644
--- a/meta/recipes-core/busybox/busybox_1.18.4.bb
+++ b/meta/recipes-core/busybox/busybox_1.18.4.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r5"
+PR = "r6"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://udhcpscript.patch \