summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-support/sqlite/sqlite3.inc12
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3.25.3.bb (renamed from meta/recipes-support/sqlite/sqlite3_3.25.2.bb)4
2 files changed, 12 insertions, 4 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3.inc b/meta/recipes-support/sqlite/sqlite3.inc
index 1834867d10..daf3db5e9f 100644
--- a/meta/recipes-support/sqlite/sqlite3.inc
+++ b/meta/recipes-support/sqlite/sqlite3.inc
@@ -21,11 +21,19 @@ CVE_PRODUCT = "sqlite"
inherit autotools pkgconfig
-PACKAGECONFIG ?= ""
-PACKAGECONFIG_class-native = ""
+# enable those which are enabled by default in configure
+PACKAGECONFIG ?= "fts4 fts5 json1 rtree dyn_ext"
+PACKAGECONFIG_class-native ?= "fts4 fts5 json1 rtree dyn_ext"
PACKAGECONFIG[editline] = "--enable-editline,--disable-editline,libedit"
PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline ncurses"
+PACKAGECONFIG[fts3] = "--enable-fts3,--disable-fts3"
+PACKAGECONFIG[fts4] = "--enable-fts4,--disable-fts4"
+PACKAGECONFIG[fts5] = "--enable-fts5,--disable-fts5"
+PACKAGECONFIG[json1] = "--enable-json1,--disable-json1"
+PACKAGECONFIG[rtree] = "--enable-rtree,--disable-rtree"
+PACKAGECONFIG[session] = "--enable-session,--disable-session"
+PACKAGECONFIG[dyn_ext] = "--enable-dynamic-extensions,--disable-dynamic-extensions"
EXTRA_OECONF = " \
--enable-shared \
diff --git a/meta/recipes-support/sqlite/sqlite3_3.25.2.bb b/meta/recipes-support/sqlite/sqlite3_3.25.3.bb
index 31c9a6f2d2..a7cf6d1b81 100644
--- a/meta/recipes-support/sqlite/sqlite3_3.25.2.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3.25.3.bb
@@ -6,5 +6,5 @@ LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=786d3dc581eff03f4fd9e4a77ed0
SRC_URI = "\
http://www.sqlite.org/2018/sqlite-autoconf-${SQLITE_PV}.tar.gz \
"
-SRC_URI[md5sum] = "bfade31d59f58badc51aeaa6ae26a5de"
-SRC_URI[sha256sum] = "da9a1484423d524d3ac793af518cdf870c8255d209e369bd6a193e9f9d0e3181"
+SRC_URI[md5sum] = "06db8206bc8febf07141b78ad58595ea"
+SRC_URI[sha256sum] = "00ebf97be13928941940cc71de3d67e9f852698233cd98ce2d178fd08092f3dd"