aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--meta/classes/image.bbclass2
-rw-r--r--meta/conf/site.conf.sample6
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb13
-rwxr-xr-xscripts/oe-find-native-sysroot (renamed from scripts/poky-find-native-sysroot)2
-rwxr-xr-xscripts/oe-git-proxy-command (renamed from scripts/poky-git-proxy-command)0
-rwxr-xr-xscripts/oe-git-proxy-socks-command2
-rw-r--r--scripts/oe-git-proxy-socks.c (renamed from scripts/poky-git-proxy-socks.c)0
-rwxr-xr-xscripts/oe-setup-rpmrepo (renamed from scripts/poky-setup-rpmrepo)0
-rwxr-xr-xscripts/oe-trim-schemas (renamed from scripts/poky-trim-schemas)0
-rwxr-xr-xscripts/poky-git-proxy-socks-command2
-rwxr-xr-xscripts/runqemu-addptable2image (renamed from scripts/poky-addptable2image)0
-rwxr-xr-xscripts/runqemu-export-rootfs (renamed from scripts/poky-export-rootfs)6
-rwxr-xr-xscripts/runqemu-extract-sdk (renamed from scripts/poky-extract-sdk)4
-rwxr-xr-xscripts/runqemu-gen-tapdevs (renamed from scripts/poky-gen-tapdevs)0
-rwxr-xr-xscripts/runqemu-ifup2
-rwxr-xr-xscripts/runqemu-internal12
17 files changed, 27 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
index c563983906..b13086deb7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,7 +7,7 @@ build/tmp/
build/sstate-cache
build/pyshtables.py
pstage/
-scripts/poky-git-proxy-socks
+scripts/oe-git-proxy-socks
sources/
meta-darwin
meta-maemo
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 7d31d04a24..b2325b3a6d 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -216,7 +216,7 @@ rootfs_trim_schemas () {
do
# Need this in case no files exist
if [ -e $schema ]; then
- poky-trim-schemas $schema > $schema.new
+ oe-trim-schemas $schema > $schema.new
mv $schema.new $schema
fi
done
diff --git a/meta/conf/site.conf.sample b/meta/conf/site.conf.sample
index 469a1660f5..d438298e84 100644
--- a/meta/conf/site.conf.sample
+++ b/meta/conf/site.conf.sample
@@ -20,7 +20,7 @@ SCONF_VERSION = "1"
# although this only works for http
#GIT_PROXY_HOST = "proxy.example.com"
#GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/poky-git-proxy-command"
+#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/oe-git-proxy-command"
# GIT_PROXY_IGNORE_* lines define hosts which do not require a proxy to access
#GIT_CORE_CONFIG = "Yes"
@@ -28,11 +28,11 @@ SCONF_VERSION = "1"
#GIT_PROXY_IGNORE_2 = "another.server.com"
# If SOCKS is available run the following command to comple a simple transport
-# gcc scripts/poky-git-proxy-socks.c -o poky-git-proxy-socks
+# gcc scripts/oe-git-proxy-socks.c -o oe-git-proxy-socks
# and then share that binary somewhere in PATH, then use the following settings
#GIT_PROXY_HOST = "proxy.example.com"
#GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/poky-git-proxy-socks-command"
+#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/oe-git-proxy-socks-command"
# Uncomment this to use a shared download directory
diff --git a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
index 10d3e64ae8..15f872beff 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
@@ -11,13 +11,13 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5
SRC_URI = "file://${COREBASE}/scripts/runqemu \
file://${COREBASE}/scripts/runqemu-internal \
- file://${COREBASE}/scripts/poky-addptable2image \
- file://${COREBASE}/scripts/poky-gen-tapdevs \
+ file://${COREBASE}/scripts/runqemu-addptable2image \
+ file://${COREBASE}/scripts/runqemu-gen-tapdevs \
file://${COREBASE}/scripts/runqemu-ifup \
file://${COREBASE}/scripts/runqemu-ifdown \
- file://${COREBASE}/scripts/poky-find-native-sysroot \
- file://${COREBASE}/scripts/poky-extract-sdk \
- file://${COREBASE}/scripts/poky-export-rootfs \
+ file://${COREBASE}/scripts/oe-find-native-sysroot \
+ file://${COREBASE}/scripts/runqemu-extract-sdk \
+ file://${COREBASE}/scripts/runqemu-export-rootfs \
file://tunctl.c \
file://raw2flash.c \
"
@@ -34,7 +34,8 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}${COREBASE}/scripts/poky-* ${D}${bindir}/
+ install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/
+ install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/
install tunctl ${D}${bindir}/
install raw2flash.spitz ${D}${bindir}/
install flash2raw.spitz ${D}${bindir}/
diff --git a/scripts/poky-find-native-sysroot b/scripts/oe-find-native-sysroot
index d44fd9536e..da00a07850 100755
--- a/scripts/poky-find-native-sysroot
+++ b/scripts/oe-find-native-sysroot
@@ -8,7 +8,7 @@
# This script is intended to be run within other scripts by source'ing
# it, e.g:
#
-# SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+# SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
# . $SYSROOT_SETUP_SCRIPT
#
# This script will terminate execution of your calling program unless
diff --git a/scripts/poky-git-proxy-command b/scripts/oe-git-proxy-command
index d31f85abd8..d31f85abd8 100755
--- a/scripts/poky-git-proxy-command
+++ b/scripts/oe-git-proxy-command
diff --git a/scripts/oe-git-proxy-socks-command b/scripts/oe-git-proxy-socks-command
new file mode 100755
index 0000000000..90fa14e1ed
--- /dev/null
+++ b/scripts/oe-git-proxy-socks-command
@@ -0,0 +1,2 @@
+#! /bin/bash
+oe-git-proxy-socks -S $GIT_PROXY_HOST:$GIT_PROXY_PORT $@
diff --git a/scripts/poky-git-proxy-socks.c b/scripts/oe-git-proxy-socks.c
index f5747117ab..f5747117ab 100644
--- a/scripts/poky-git-proxy-socks.c
+++ b/scripts/oe-git-proxy-socks.c
diff --git a/scripts/poky-setup-rpmrepo b/scripts/oe-setup-rpmrepo
index 03372b6199..03372b6199 100755
--- a/scripts/poky-setup-rpmrepo
+++ b/scripts/oe-setup-rpmrepo
diff --git a/scripts/poky-trim-schemas b/scripts/oe-trim-schemas
index 29fb3a1b67..29fb3a1b67 100755
--- a/scripts/poky-trim-schemas
+++ b/scripts/oe-trim-schemas
diff --git a/scripts/poky-git-proxy-socks-command b/scripts/poky-git-proxy-socks-command
deleted file mode 100755
index a5af2d33fa..0000000000
--- a/scripts/poky-git-proxy-socks-command
+++ /dev/null
@@ -1,2 +0,0 @@
-#! /bin/bash
-poky-git-proxy-socks -S $GIT_PROXY_HOST:$GIT_PROXY_PORT $@
diff --git a/scripts/poky-addptable2image b/scripts/runqemu-addptable2image
index f0195ad8a3..f0195ad8a3 100755
--- a/scripts/poky-addptable2image
+++ b/scripts/runqemu-addptable2image
diff --git a/scripts/poky-export-rootfs b/scripts/runqemu-export-rootfs
index 764d19a823..0076768d20 100755
--- a/scripts/poky-export-rootfs
+++ b/scripts/runqemu-export-rootfs
@@ -38,9 +38,9 @@ fi
# Ensure the nfs-export-dir is an absolute path
NFS_EXPORT_DIR=$(cd "$2" && pwd)
-SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
- echo "Error: Unable to find the poky-find-native-sysroot script"
+ echo "Error: Unable to find the oe-find-native-sysroot script"
echo "Did you forget to source your Poky environment script?"
exit 1
fi
@@ -73,7 +73,7 @@ export PSEUDO_LOCALSTATEDIR
if [ ! -d "$PSEUDO_LOCALSTATEDIR" ]; then
echo "Error: $PSEUDO_LOCALSTATEDIR does not exist."
- echo "Did you create the export directory using poky-extract-sdk?"
+ echo "Did you create the export directory using runqemu-extract-sdk?"
exit 1
fi
diff --git a/scripts/poky-extract-sdk b/scripts/runqemu-extract-sdk
index ee2682e74a..ed349dd306 100755
--- a/scripts/poky-extract-sdk
+++ b/scripts/runqemu-extract-sdk
@@ -29,9 +29,9 @@ if [ $# -ne 2 ]; then
exit 1
fi
-SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
- echo "Error: Unable to find the poky-find-native-sysroot script"
+ echo "Error: Unable to find the oe-find-native-sysroot script"
echo "Did you forget to source your Poky environment script?"
exit 1
fi
diff --git a/scripts/poky-gen-tapdevs b/scripts/runqemu-gen-tapdevs
index 527c01e7b4..527c01e7b4 100755
--- a/scripts/poky-gen-tapdevs
+++ b/scripts/runqemu-gen-tapdevs
diff --git a/scripts/runqemu-ifup b/scripts/runqemu-ifup
index c963af5df9..a3914140a6 100755
--- a/scripts/runqemu-ifup
+++ b/scripts/runqemu-ifup
@@ -14,7 +14,7 @@
# <my-username> ALL=NOPASSWD: /path/to/runqemu-ifdown
#
# If you'd like to create a bank of tap devices at once, you should use
-# the poky-gen-tapdevs script instead. If tap devices are set up using
+# the runqemu-gen-tapdevs script instead. If tap devices are set up using
# that script, the runqemu script will never end up calling this
# script.
#
diff --git a/scripts/runqemu-internal b/scripts/runqemu-internal
index 64374f2076..adf2b47aae 100755
--- a/scripts/runqemu-internal
+++ b/scripts/runqemu-internal
@@ -83,7 +83,7 @@ fi
if [ -z "$mem_set" ] ; then
SCRIPT_QEMU_EXTRA_OPT="$SCRIPT_QEMU_EXTRA_OPT -m $mem_size"
fi
-# This file is created when poky-gen-tapdevs creates a bank of tap
+# This file is created when runqemu-gen-tapdevs creates a bank of tap
# devices, indicating that the user should not bring up new ones using
# sudo.
NOSUDO_FLAG="/etc/poky-nosudo"
@@ -186,8 +186,8 @@ cleanup() {
if [ "$NFSRUNNING" = "true" ]; then
echo "Shutting down the userspace NFS server..."
- echo "poky-export-rootfs stop $ROOTFS"
- poky-export-rootfs stop $ROOTFS
+ echo "runqemu-export-rootfs stop $ROOTFS"
+ runqemu-export-rootfs stop $ROOTFS
fi
# If QEMU crashes or somehow tty properties are not restored
# after qemu exits, we need to run stty sane
@@ -258,8 +258,8 @@ if [ "$FSTYPE" = "nfs" ]; then
fi
# Start the userspace NFS server
- echo "poky-export-rootfs restart $ROOTFS"
- poky-export-rootfs restart $ROOTFS
+ echo "runqemu-export-rootfs restart $ROOTFS"
+ runqemu-export-rootfs restart $ROOTFS
if [ $? != 0 ]; then
cleanup
return
@@ -351,7 +351,7 @@ if [ "$MACHINE" = "spitz" ]; then
echo $ROOTFS
if [ ! -e "$ROOTFS.qemudisk" ]; then
echo "Adding a partition table to the ext3 image for use by QEMU, please wait..."
- poky-addptable2image $ROOTFS $ROOTFS.qemudisk
+ runqemu-addptable2image $ROOTFS $ROOTFS.qemudisk
fi
QEMUOPTIONS="$QEMU_NETWORK_CMD -M spitz -hda $ROOTFS.qemudisk -portrait"
fi