aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/glibc-site/glibc-site_2.28.bb21
-rw-r--r--meta/recipes-core/glibc-site/site_config/funcs66
-rw-r--r--meta/recipes-core/glibc-site/site_config/headers64
-rw-r--r--meta/recipes-core/glibc-site/site_config/types21
4 files changed, 172 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc-site/glibc-site_2.28.bb b/meta/recipes-core/glibc-site/glibc-site_2.28.bb
new file mode 100644
index 0000000000..937209886c
--- /dev/null
+++ b/meta/recipes-core/glibc-site/glibc-site_2.28.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Create glibc site config for speeding up do_configure"
+
+# The LICENSE is the same as glibc
+LICENSE = "GPLv2 & LGPLv2.1"
+SECTION = "libs"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}compilerlibs virtual/libc"
+
+inherit autotools nopackages
+
+do_compile() {
+ :
+}
+
+do_install() {
+ :
+}
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-core/glibc-site/site_config/funcs b/meta/recipes-core/glibc-site/site_config/funcs
new file mode 100644
index 0000000000..d80bb1fdd7
--- /dev/null
+++ b/meta/recipes-core/glibc-site/site_config/funcs
@@ -0,0 +1,66 @@
+bind_textdomain_codeset
+clock_gettime
+fcntl
+fork
+ftruncate
+getaddrinfo
+getcwd
+geteuid
+getgrgid_r
+gethostbyname
+getline
+getopt_long_only
+getpagesize
+getpwuid_r
+gettimeofday
+getuid
+localtime_r
+mbrtowc
+memcpy
+memmove
+mempcpy
+memset
+mkstemp
+mmap
+mprotect
+nl_langinfo
+pipe
+poll
+putenv
+raise
+readlink
+realpath
+select
+setenv
+setlocale
+setresuid
+sigaction
+snprintf
+socket
+stpcpy
+strcasecmp
+strchr
+strdup
+strerror
+strerror_r
+strftime
+strncasecmp
+strndup
+strnlen
+strrchr
+strstr
+strtol
+strtoul
+symlink
+sysconf
+towlower
+tsearch
+unsetenv
+vasprintf
+vfork
+vprintf
+vsnprintf
+waitpid
+wcrtomb
+wcslen
+wcsnlen
diff --git a/meta/recipes-core/glibc-site/site_config/headers b/meta/recipes-core/glibc-site/site_config/headers
new file mode 100644
index 0000000000..871466d77f
--- /dev/null
+++ b/meta/recipes-core/glibc-site/site_config/headers
@@ -0,0 +1,64 @@
+alloca.h
+arpa/inet.h
+byteswap.h
+ctype.h
+dirent.h
+dlfcn.h
+endian.h
+errno.h
+execinfo.h
+fcntl.h
+features.h
+float.h
+getopt.h
+grp.h
+iconv.h
+inttypes.h
+langinfo.h
+libintl.h
+limits.h
+locale.h
+malloc.h
+math.h
+memory.h
+netdb.h
+netinet/in.h
+poll.h
+pthread.h
+pwd.h
+search.h
+signal.h
+stdio_ext.h
+stdlib.h
+string.h
+strings.h
+stropts.h
+sys/cdefs.h
+sys/file.h
+sys/ioctl.h
+syslog.h
+sys/mman.h
+sys/param.h
+sys/poll.h
+sys/prctl.h
+sys/resource.h
+sys/select.h
+sys/socket.h
+sys/stat.h
+sys/statvfs.h
+sys/sysctl.h
+sys/sysmacros.h
+sys/time.h
+sys/times.h
+sys/types.h
+sys/uio.h
+sys/un.h
+sys/utsname.h
+sys/wait.h
+sys/xattr.h
+termios.h
+time.h
+unistd.h
+utime.h
+wchar.h
+wctype.h
diff --git a/meta/recipes-core/glibc-site/site_config/types b/meta/recipes-core/glibc-site/site_config/types
new file mode 100644
index 0000000000..178bd85a00
--- /dev/null
+++ b/meta/recipes-core/glibc-site/site_config/types
@@ -0,0 +1,21 @@
+char
+char *
+double
+float
+int
+long
+long double
+long int
+long long
+long long int
+short
+short int
+signed char
+unsigned char
+unsigned int
+unsigned long
+unsigned long int
+unsigned long long int
+unsigned short
+unsigned short int
+void *