aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-bsp/hostap/hostap-conf_1.0.bb4
-rw-r--r--meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb4
-rw-r--r--meta/recipes-bsp/orinoco/orinoco-conf_1.0.bb4
-rw-r--r--meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb4
-rw-r--r--meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb4
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.22.bb2
-rw-r--r--meta/recipes-core/dropbear/dropbear.inc4
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb4
-rw-r--r--meta/recipes-extended/bash/bash.inc2
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb2
-rw-r--r--meta/recipes-extended/sudo/sudo.inc2
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb2
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb2
-rw-r--r--meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb2
-rw-r--r--meta/recipes-kernel/update-modules/update-modules_1.0.bb2
15 files changed, 22 insertions, 22 deletions
diff --git a/meta/recipes-bsp/hostap/hostap-conf_1.0.bb b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
index fa294704859..de72b769a95 100644
--- a/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
+++ b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
@@ -19,13 +19,13 @@ do_install() {
install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
if [ -n "$D" ]; then
exit 1
fi
update-modules || true
}
-pkg_postrm () {
+pkg_postrm_${PN} () {
update-modules || true
}
diff --git a/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb b/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
index 6d08084b194..4cefdb79667 100644
--- a/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
+++ b/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
@@ -28,13 +28,13 @@ do_install() {
install -m 0755 src/lrz src/lsz ${D}${bindir}/
}
-pkg_postinst() {
+pkg_postinst_${PN}() {
for util in rz rx rb sz sx sb; do
update-alternatives --install ${bindir}/$util $util lrz 100
done
}
-pkg_postrm() {
+pkg_postrm_${PN}() {
for util in rz rx rb sz sx sb; do
update-alternatives --remove $util ${bindir}/lrz
done
diff --git a/meta/recipes-bsp/orinoco/orinoco-conf_1.0.bb b/meta/recipes-bsp/orinoco/orinoco-conf_1.0.bb
index a24d004adbd..1c25e02dccf 100644
--- a/meta/recipes-bsp/orinoco/orinoco-conf_1.0.bb
+++ b/meta/recipes-bsp/orinoco/orinoco-conf_1.0.bb
@@ -15,13 +15,13 @@ do_install() {
install -m 0644 ${WORKDIR}/orinoco_cs.conf ${D}${sysconfdir}/modutils/
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
if [ -n "$D" ]; then
exit 1
fi
update-modules || true
}
-pkg_postrm () {
+pkg_postrm_${PN} () {
update-modules || true
}
diff --git a/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb b/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb
index 4c94d2aeaf8..b04b20abee2 100644
--- a/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb
+++ b/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb
@@ -25,14 +25,14 @@ DEBIANNAME_${PN} = "libnss-mdns"
EXTRA_OECONF = "--libdir=/lib --disable-lynx --enable-avahi"
# TODO: pattern based configuration update
-pkg_postinst () {
+pkg_postinst_${PN} () {
cat /etc/nsswitch.conf | grep "hosts:\s*files dns$" > /dev/null && {
cat /etc/nsswitch.conf | sed 's/hosts:\s*files dns/& mdns4/' > /tmp/nsswitch.conf
mv /tmp/nsswitch.conf /etc/nsswitch.conf
}
}
-pkg_prerm () {
+pkg_prerm_${PN} () {
cat /etc/nsswitch.conf | grep "hosts:\s*files dns mdns4$" > /dev/null && {
cat /etc/nsswitch.conf | sed 's/\(hosts:\s*files dns\) mdns4*/\1/' > /tmp/nsswitch.conf
mv /tmp/nsswitch.conf /etc/nsswitch.conf
diff --git a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
index aa3684a440c..f57597d80c8 100644
--- a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
+++ b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
@@ -20,7 +20,7 @@ do_install() {
PACKAGE_ARCH = "all"
-pkg_postinst() {
+pkg_postinst_${PN} () {
if test "x$D" != "x"; then
exit 1
else
@@ -28,7 +28,7 @@ else
fi
}
-pkg_postrm() {
+pkg_postrm_${PN} () {
if test "x$D" != "x"; then
exit 1
else
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
index b8263671de2..aed84914bf2 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
@@ -40,7 +40,7 @@ do_install_append_openmn() {
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
set -e
if [ ! -e $D${sysconfdir}/passwd ] ; then
diff --git a/meta/recipes-core/dropbear/dropbear.inc b/meta/recipes-core/dropbear/dropbear.inc
index dd2f0c5b530..ab7719c4691 100644
--- a/meta/recipes-core/dropbear/dropbear.inc
+++ b/meta/recipes-core/dropbear/dropbear.inc
@@ -63,12 +63,12 @@ do_install() {
chmod 755 ${D}${sysconfdir}/init.d/dropbear
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
update-alternatives --install ${bindir}/scp scp ${sbindir}/dropbearmulti 20
update-alternatives --install ${bindir}/ssh ssh ${sbindir}/dropbearmulti 20
}
-pkg_postrm_append () {
+pkg_postrm_append_${PN} () {
if [ -f "${sysconfdir}/dropbear/dropbear_rsa_host_key" ]; then
rm ${sysconfdir}/dropbear/dropbear_rsa_host_key
fi
diff --git a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
index 92014a80eee..63e0acdba79 100644
--- a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
+++ b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
@@ -31,7 +31,7 @@ do_compile_append() {
FILES_sgml-common_append = " ${datadir}/sgml"
-pkg_postinst() {
+pkg_postinst_${PN}() {
install-catalog \
--add ${sysconfdir}/sgml/sgml-ent.cat \
${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
@@ -41,7 +41,7 @@ pkg_postinst() {
${sysconfdir}/sgml/sgml-ent.cat
}
-pkg_postrm() {
+pkg_postrm_${PN}() {
install-catalog \
--remove ${sysconfdir}/sgml/sgml-ent.cat \
${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index a87b87ff4b9..ecbd75dadd1 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -27,7 +27,7 @@ do_configure () {
oe_runconf
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
index e5a3e3643d1..0912ad6aa8c 100644
--- a/meta/recipes-extended/bash/bash_3.2.48.bb
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -28,7 +28,7 @@ do_configure () {
oe_runconf
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
diff --git a/meta/recipes-extended/sudo/sudo.inc b/meta/recipes-extended/sudo/sudo.inc
index 1407bf10c58..6a04a9c0b09 100644
--- a/meta/recipes-extended/sudo/sudo.inc
+++ b/meta/recipes-extended/sudo/sudo.inc
@@ -23,7 +23,7 @@ do_configure_prepend () {
fi
}
-pkg_postinst() {
+pkg_postinst_${PN} () {
if [ "x$D" != "x" ]; then
exit 1
fi
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
index 12d9d867219..c50d6eb3ffa 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
@@ -32,7 +32,7 @@ do_install () {
install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
#!/bin/sh
fc-cache
}
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
index 887536a4f00..f6bf0ce66fd 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
@@ -33,7 +33,7 @@ do_install () {
install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
#!/bin/sh
fc-cache
}
diff --git a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
index b9a75a77bba..bdeb4c19b5f 100644
--- a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
+++ b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -31,7 +31,7 @@ do_install () {
done
}
-pkg_postinst () {
+pkg_postinst_${PN} () {
#!/bin/sh
fc-cache
}
diff --git a/meta/recipes-kernel/update-modules/update-modules_1.0.bb b/meta/recipes-kernel/update-modules/update-modules_1.0.bb
index a473bb58c7a..a8ebbdaebd1 100644
--- a/meta/recipes-kernel/update-modules/update-modules_1.0.bb
+++ b/meta/recipes-kernel/update-modules/update-modules_1.0.bb
@@ -10,7 +10,7 @@ PR = "r8"
SRC_URI = "file://update-modules \
file://COPYING.GPL"
-pkg_postinst() {
+pkg_postinst_${PN} () {
if [ "x$D" != "x" ]; then
exit 1
fi