aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.12.0.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.12.0.bb b/meta/recipes-graphics/wayland/wayland_1.12.0.bb
index de261fe9b1..026227a533 100644
--- a/meta/recipes-graphics/wayland/wayland_1.12.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.12.0.bb
@@ -10,20 +10,17 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
+DEPENDS = "expat libxml2 libffi wayland-native"
+
SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
"
SRC_URI[md5sum] = "ee615e2d1e205eec48b02f069327eb96"
SRC_URI[sha256sum] = "d6b4135cba0188abcb7275513c72dede751d6194f6edc5b82183a3ba8b821ab1"
-EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
-
inherit autotools pkgconfig
-BBCLASSEXTEND = "native nativesdk"
-
-DEPENDS = "expat libxml2 libffi wayland-native"
-
EXTRA_OECONF = "--disable-documentation --with-host-scanner"
+EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
# Wayland installs a M4 macro for other projects to use, which uses the target
# pkg-config to find files. Replace pkg-config with pkg-config-native.
@@ -40,3 +37,5 @@ sysroot_stage_all_append_class-target () {
FILES_${PN} = "${libdir}/*${SOLIBS}"
FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
+
+BBCLASSEXTEND = "native nativesdk"