aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/lsb/lsbtest/LSB_Test.sh4
-rw-r--r--meta/recipes-extended/lsb/lsbtest/session11
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb5
3 files changed, 5 insertions, 15 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh b/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
index 0eb2793b10..073e247a58 100644
--- a/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
+++ b/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
@@ -60,7 +60,7 @@ fi
PACKAGES_DIR="/var/opt/lsb/test/manager/packages/ftp.linuxfoundation.org/pub/lsb"
-BASE_PACKAGES_DIR="${PACKAGES_DIR}/base/${LSB_RELEASE}/binary"
+BASE_PACKAGES_DIR="${PACKAGES_DIR}/base/released-all/binary"
RUNTIME_BASE_PACKAGES_DIR="${PACKAGES_DIR}/test_suites/released-all/binary/runtime"
RUNTIME_PACKAGES_DIR="${PACKAGES_DIR}/test_suites/${LSB_RELEASE}/binary/runtime"
APP_PACKAGES_DIR="${PACKAGES_DIR}/app-battery/${LSB_RELEASE}/${LSB_ARCH}"
@@ -98,7 +98,7 @@ then
fi
# Official download server list. You can replace them with your own server.
-SERVER_IPADDR="140.211.169.23"
+SERVER_IPADDR="140.211.169.28"
SERVER_NAME="ftp.linuxfoundation.org"
if ! `grep -F -q "${SERVER_NAME}" /etc/hosts`; then
diff --git a/meta/recipes-extended/lsb/lsbtest/session b/meta/recipes-extended/lsb/lsbtest/session
index 3abcca740b..4d47e40f7d 100644
--- a/meta/recipes-extended/lsb/lsbtest/session
+++ b/meta/recipes-extended/lsb/lsbtest/session
@@ -2,7 +2,7 @@
VERBOSE_LEVEL: 1
ARCHITECTURE: targetarch
USE_INTERNET: 1
-STD_VERSION: LSB 4.1
+STD_VERSION: LSB 5.0
STD_PROFILE: no
[cmdchk]
RUN: 1
@@ -126,15 +126,6 @@ VERSION: local|*
AUTOREPLY_TESTSUITE_DIR: /opt/lsb/test/python
AUTOREPLY_RESULTS_DIR: /opt/lsb/test/python/results
-[qt4-azov]
-RUN: 1
-VERSION: local|*
-
-[qt4-azov|local|*]
-AUTOREPLY_TESTSUITE_DIR: /opt/lsb/test/qt4-azov
-AUTOREPLY_X11_FONT_PATH: [default]
-AUTOREPLY_RESULTS_DIR: /opt/lsb/test/qt4-azov/results
-
[xml2-azov]
RUN: 1
VERSION: local|*
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
index 36f52fd73a..a90c023d52 100644
--- a/meta/recipes-extended/lsb/lsbtest_1.0.bb
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -10,14 +10,13 @@ SRC_URI = "file://LSB_Test.sh \
file://packages_list \
file://session \
"
-RDEPENDS_${PN} = "rpm"
+RDEPENDS_${PN} = "lsb rpm"
S = "${WORKDIR}"
do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${S}/LSB_Test.sh ${D}${bindir}
install -d ${D}/opt/lsb-test
+ install -m 0755 ${S}/LSB_Test.sh ${D}/opt/lsb-test/LSB_Test.sh
install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
install -m 0644 ${S}/session ${D}/opt/lsb-test/session
if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then