aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/classes/libc-common.bbclass5
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb2
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb1
3 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/libc-common.bbclass b/meta/classes/libc-common.bbclass
index 962f205f81..9b91f0a1a6 100644
--- a/meta/classes/libc-common.bbclass
+++ b/meta/classes/libc-common.bbclass
@@ -27,4 +27,9 @@ python populate_packages_prepend () {
bpn = d.getVar('BPN', True)
d.setVar('PKG_'+bpn, 'libc6')
d.setVar('PKG_'+bpn+'-dev', 'libc6-dev')
+ d.setVar('PKG_'+bpn+'-dbg', 'libc6-dbg')
+ # For backward compatibility with old -dbg package
+ d.setVar('RPROVIDES_' + bpn + '-dbg', 'libc-dbg')
+ d.setVar('RCONFLICTS_' + bpn + '-dbg', 'libc-dbg')
+ d.setVar('RREPLACES_' + bpn + '-dbg', 'libc-dbg')
}
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index e718a1f93e..a4f59b62ce 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "15508"
DEPENDS += "gperf-native"
-PR = "r20"
+PR = "r21"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_13"
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index b4c1ea5a99..3820f5aa09 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -3,6 +3,7 @@ require eglibc.inc
SRCREV = "16540"
DEPENDS += "gperf-native"
+PR = "r1"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_15"