summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/pseudo/pseudo-test.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo-test.bb b/meta/recipes-devtools/pseudo/pseudo-test.bb
new file mode 100644
index 0000000000..90581ef763
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo-test.bb
@@ -0,0 +1,21 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit allarch
+
+DEPENDS = "coreutils-native"
+CLEANBROKEN = "1"
+
+RULES = "1000"
+
+do_compile() {
+ echo > Makefile; ALL="all: "; for i in `seq -w 1 ${RULES}`; do echo -e "R$i:\n\techo $i > foo.txt" >> Makefile; ALL="$ALL R$i"; done; echo ${ALL} >> Makefile
+}
+
+do_install() {
+ oe_runmake all
+ cat foo.txt
+ mv foo.txt ${D}
+}
+
+FILES_${PN} = "/"