aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.7.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.7.1.bb b/meta/recipes-devtools/gdb/gdb_7.7.1.bb
index 1abc9d8e76..bc042ec013 100644
--- a/meta/recipes-devtools/gdb/gdb_7.7.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.7.1.bb
@@ -7,6 +7,9 @@ PACKAGECONFIG ??= ""
PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
+# cc1 (4.9) call with -mthumb gets stuck and eats all available memory (over 20GB in my case)
+ARM_INSTRUCTION_SET = "arm"
+
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
cat > ${WORKDIR}/python << EOF