summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/python/python3-wheel_0.37.1.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index 91bff82509..83a7c986a8 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a01
SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
-inherit flit_core pypi setuptools3-base
+inherit flit_core pypi
SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
@@ -15,9 +15,7 @@ DEPENDS:remove:class-native = "python3-pip-native"
do_install:class-native () {
# We need to bootstrap python3-wheel-native
install -d ${D}${PYTHON_SITEPACKAGES_DIR}
- PYPA_WHEEL="${B}/dist/${PYPI_PACKAGE}-${PV}-*.whl"
- unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PYPA_WHEEL} || \
- bbfatal_log "Failed to install"
+ unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PIP_INSTALL_DIST_PATH}/*.whl
# pip install would normally generate [project.scripts] in ${bindir}
install -d ${D}/${bindir}
@@ -37,4 +35,3 @@ EOF
}
BBCLASSEXTEND = "native nativesdk"
-