aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/bsp-guide/bsp.xml4
-rw-r--r--documentation/dev-manual/dev-manual-common-tasks.xml22
-rw-r--r--documentation/dev-manual/dev-manual-newbie.xml6
-rwxr-xr-x[-rw-r--r--]documentation/mega-manual/figures/user-configuration.pngbin23687 -> 74109 bytes
-rw-r--r--documentation/ref-manual/closer-look.xml6
-rwxr-xr-x[-rw-r--r--]documentation/ref-manual/figures/user-configuration.pngbin23687 -> 74109 bytes
-rw-r--r--documentation/ref-manual/ref-structure.xml20
-rw-r--r--documentation/ref-manual/ref-variables.xml16
-rw-r--r--documentation/toaster-manual/toaster-manual-reference.xml32
-rw-r--r--documentation/toaster-manual/toaster-manual-setup-and-use.xml2
10 files changed, 54 insertions, 54 deletions
diff --git a/documentation/bsp-guide/bsp.xml b/documentation/bsp-guide/bsp.xml
index 9ac72991f6..b0562c7d4d 100644
--- a/documentation/bsp-guide/bsp.xml
+++ b/documentation/bsp-guide/bsp.xml
@@ -110,7 +110,7 @@
<literallayout class='monospaced'>
BBLAYERS ?= " \
/usr/local/src/yocto/meta \
- /usr/local/src/yocto/meta-yocto \
+ /usr/local/src/yocto/meta-poky \
/usr/local/src/yocto/meta-yocto-bsp \
/usr/local/src/yocto/meta-mylayer \
"
@@ -1536,7 +1536,7 @@
<literallayout class='monospaced'>
BBLAYERS = ? " \
/usr/local/src/yocto/meta \
- /usr/local/src/yocto/meta-yocto \
+ /usr/local/src/yocto/meta-poky \
/usr/local/src/yocto/meta-yocto-bsp \
/usr/local/src/yocto/meta-myarm \
"
diff --git a/documentation/dev-manual/dev-manual-common-tasks.xml b/documentation/dev-manual/dev-manual-common-tasks.xml
index 00cad99599..927dcf021b 100644
--- a/documentation/dev-manual/dev-manual-common-tasks.xml
+++ b/documentation/dev-manual/dev-manual-common-tasks.xml
@@ -72,7 +72,7 @@
<filename>meta</filename>,
<filename>meta-skeleton</filename>,
<filename>meta-selftest</filename>,
- <filename>meta-yocto</filename>, and
+ <filename>meta-poky</filename>, and
<filename>meta-yocto-bsp</filename>.
Each of these folders represents a distinct layer.
</para>
@@ -165,12 +165,12 @@
directory to the
<filename>BBPATH</filename>.
On the other hand, distro layers, such as
- <filename>meta-yocto</filename>, can choose
+ <filename>meta-poky</filename>, can choose
to enforce their own precedence over
<filename>BBPATH</filename>.
For an example of that syntax, see the
<filename>layer.conf</filename> file for
- the <filename>meta-yocto</filename> layer.
+ the <filename>meta-poky</filename> layer.
</note></para></listitem>
<listitem><para>The recipes for the layers are
appended to
@@ -444,7 +444,7 @@
BBLAYERS ?= " \
$HOME/poky/meta \
- $HOME/poky/meta-yocto \
+ $HOME/poky/meta-poky \
$HOME/poky/meta-yocto-bsp \
$HOME/poky/meta-mylayer \
"
@@ -870,7 +870,7 @@
<literallayout class='monospaced'>
BBLAYERS = ?" \
/usr/local/src/yocto/meta \
- /usr/local/src/yocto/meta-yocto \
+ /usr/local/src/yocto/meta-poky \
/usr/local/src/yocto/meta-yocto-bsp \
/usr/local/src/yocto/meta-mylayer \
"
@@ -5511,14 +5511,14 @@
<filename>poky/build/conf</filename> directory needs to have the path to your local
<filename>meta-mylayer</filename> layer.
By default, the <filename>BBLAYERS</filename> variable contains paths to
- <filename>meta</filename>, <filename>meta-yocto</filename>, and
+ <filename>meta</filename>, <filename>meta-poky</filename>, and
<filename>meta-yocto-bsp</filename> in the
<filename>poky</filename> Git repository.
Add the path to your <filename>meta-mylayer</filename> location:
<literallayout class='monospaced'>
BBLAYERS ?= " \
$HOME/poky/meta \
- $HOME/poky/meta-yocto \
+ $HOME/poky/meta-poky \
$HOME/poky/meta-yocto-bsp \
$HOME/poky/meta-mylayer \
"
@@ -5987,7 +5987,7 @@
By default, <filename>TEMPLATECONF</filename> is set as
follows in the <filename>poky</filename> repository:
<literallayout class='monospaced'>
- TEMPLATECONF=${TEMPLATECONF:-meta-yocto/conf}
+ TEMPLATECONF=${TEMPLATECONF:-meta-poky/conf}
</literallayout>
This is the directory used by the build system to find templates
from which to build some key configuration files.
@@ -6039,7 +6039,7 @@
<para>
Aside from the <filename>*.sample</filename> configuration files,
the <filename>conf-notes.txt</filename> also resides in the
- default <filename>meta-yocto/conf</filename> directory.
+ default <filename>meta-poky/conf</filename> directory.
The scripts that set up the build environment
(i.e.
<ulink url="&YOCTO_DOCS_REF_URL;#structure-core-script"><filename>&OE_INIT_FILE;</filename></ulink>
@@ -10215,7 +10215,7 @@
</literallayout>
One thing a development organization might want to consider
for end-user convenience is to modify
- <filename>meta-yocto/conf/bblayers.conf.sample</filename> to
+ <filename>meta-poky/conf/bblayers.conf.sample</filename> to
ensure that when the end user utilizes the released build
system to build an image, the development organization's
layers are included in the <filename>bblayers.conf</filename>
@@ -10230,7 +10230,7 @@
BBLAYERS ?= " \
##OEROOT##/meta \
- ##OEROOT##/meta-yocto \
+ ##OEROOT##/meta-poky \
##OEROOT##/meta-yocto-bsp \
##OEROOT##/meta-mylayer \
"
diff --git a/documentation/dev-manual/dev-manual-newbie.xml b/documentation/dev-manual/dev-manual-newbie.xml
index 6d4092f02c..75c992f16b 100644
--- a/documentation/dev-manual/dev-manual-newbie.xml
+++ b/documentation/dev-manual/dev-manual-newbie.xml
@@ -603,7 +603,7 @@
the
<link linkend='build-directory'>Build Directory</link>
contains user-defined variables that affect every build.
- The <filename>meta-yocto/conf/distro/poky.conf</filename>
+ The <filename>meta-poky/conf/distro/poky.conf</filename>
configuration file defines Yocto "distro" configuration
variables used only when building with this policy.
Machine configuration files, which
@@ -1404,7 +1404,7 @@
Examine the <filename>maintainers.inc</filename> file, which is
located in the
<link linkend='source-directory'>Source Directory</link>
- at <filename>meta-yocto/conf/distro/include</filename>, to
+ at <filename>meta-poky/conf/distro/include</filename>, to
see who is responsible for code.
</para></listitem>
<listitem><para><emphasis>Board Support Package (BSP) README Files:</emphasis>
@@ -1448,7 +1448,7 @@
<listitem><para>For changes to BitBake (anything under the <filename>bitbake</filename>
directory), send your patch to the
<ulink url='&OE_LISTS_URL;/listinfo/bitbake-devel'>bitbake-devel</ulink> mailing list.</para></listitem>
- <listitem><para>For changes to <filename>meta-yocto</filename>, send your patch to the
+ <listitem><para>For changes to <filename>meta-poky</filename>, send your patch to the
<ulink url='&YOCTO_LISTS_URL;/listinfo/poky'>poky</ulink> mailing list.</para></listitem>
<listitem><para>For changes to other layers hosted on
<filename>yoctoproject.org</filename> (unless the
diff --git a/documentation/mega-manual/figures/user-configuration.png b/documentation/mega-manual/figures/user-configuration.png
index f2b3f8e7fe..c298401fc3 100644..100755
--- a/documentation/mega-manual/figures/user-configuration.png
+++ b/documentation/mega-manual/figures/user-configuration.png
Binary files differ
diff --git a/documentation/ref-manual/closer-look.xml b/documentation/ref-manual/closer-look.xml
index 42b99980a3..84ff584bad 100644
--- a/documentation/ref-manual/closer-look.xml
+++ b/documentation/ref-manual/closer-look.xml
@@ -73,7 +73,7 @@
</para>
<para>
- <imagedata fileref="figures/user-configuration.png" align="center" width="5.5in" depth="3.5in" />
+ <imagedata fileref="figures/user-configuration.png" align="center" />
</para>
<para>
@@ -100,7 +100,7 @@
</para>
<para>
- The <filename>meta-yocto</filename> layer inside Poky contains
+ The <filename>meta-poky</filename> layer inside Poky contains
a <filename>conf</filename> directory that has example
configuration files.
These example files are used as a basis for creating actual
@@ -158,7 +158,7 @@
To see the default configurations in a <filename>local.conf</filename>
file created by the build environment script, see the
<filename>local.conf.sample</filename> in the
- <filename>meta-yocto</filename> layer:
+ <filename>meta-poky</filename> layer:
<itemizedlist>
<listitem><para><emphasis>Parallelism Options:</emphasis>
Controlled by the
diff --git a/documentation/ref-manual/figures/user-configuration.png b/documentation/ref-manual/figures/user-configuration.png
index f2b3f8e7fe..c298401fc3 100644..100755
--- a/documentation/ref-manual/figures/user-configuration.png
+++ b/documentation/ref-manual/figures/user-configuration.png
Binary files differ
diff --git a/documentation/ref-manual/ref-structure.xml b/documentation/ref-manual/ref-structure.xml
index a0b36f034b..e51ceb1bf5 100644
--- a/documentation/ref-manual/ref-structure.xml
+++ b/documentation/ref-manual/ref-structure.xml
@@ -123,8 +123,8 @@
</para>
</section>
- <section id='structure-core-meta-yocto'>
- <title><filename>meta-yocto/</filename></title>
+ <section id='structure-core-meta-poky'>
+ <title><filename>meta-poky/</filename></title>
<para>
This directory contains the configuration for the Poky
@@ -233,7 +233,7 @@
</literallayout>
The script gets its default list of common targets from the
<filename>conf-notes.txt</filename> file, which is found in the
- <filename>meta-yocto</filename> directory within the
+ <filename>meta-poky</filename> directory within the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
Should you have custom distributions, it is very easy to modify
this configuration file to include your targets for your
@@ -260,7 +260,7 @@
</literallayout>
The OpenEmbedded build system uses the template configuration
files, which are found by default in the
- <filename>meta-yocto/conf</filename> directory in the
+ <filename>meta-poky/conf</filename> directory in the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
See the
"<ulink url='&YOCTO_DOCS_DEV_URL;#creating-a-custom-template-configuration-directory'>Creating a Custom Template Configuration Directory</ulink>"
@@ -373,7 +373,7 @@
</literallayout>
The script gets its default list of common targets from the
<filename>conf-notes.txt</filename> file, which is found in the
- <filename>meta-yocto</filename> directory within the
+ <filename>meta-poky</filename> directory within the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
Should you have custom distributions, it is very easy to modify
this configuration file to include your targets for your
@@ -409,7 +409,7 @@
<para>
The OpenEmbedded build system uses the template configuration
files, which are found by default in the
- <filename>meta-yocto/conf</filename> directory in the
+ <filename>meta-poky/conf</filename> directory in the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
See the
"<ulink url='&YOCTO_DOCS_DEV_URL;#creating-a-custom-template-configuration-directory'>Creating a Custom Template Configuration Directory</ulink>"
@@ -513,7 +513,7 @@
<para>
The source <filename>local.conf.sample</filename> file used
depends on the <filename>$TEMPLATECONF</filename> script variable,
- which defaults to <filename>meta-yocto/conf</filename>
+ which defaults to <filename>meta-poky/conf</filename>
when you are building from the Yocto Project development
environment and defaults to <filename>meta/conf</filename> when
you are building from the OpenEmbedded Core environment.
@@ -536,7 +536,7 @@
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
You can find the Yocto Project version of the
<filename>local.conf.sample</filename> file in the
- <filename>meta-yocto/conf</filename> directory.
+ <filename>meta-poky/conf</filename> directory.
</note>
</para>
</section>
@@ -567,7 +567,7 @@
<para>
The source <filename>bblayers.conf.sample</filename> file used
depends on the <filename>$TEMPLATECONF</filename> script variable,
- which defaults to <filename>meta-yocto/conf</filename>
+ which defaults to <filename>meta-poky/conf</filename>
when you are building from the Yocto Project development
environment and defaults to <filename>meta/conf</filename> when
you are building from the OpenEmbedded Core environment.
@@ -588,7 +588,7 @@
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
You can find the Yocto Project version of the
<filename>bblayers.conf.sample</filename> file in the
- <filename>meta-yocto/conf</filename> directory.
+ <filename>meta-poky/conf</filename> directory.
</note>
</para>
</section>
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 3e0c151415..244f68a3f7 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -1130,7 +1130,7 @@
<literallayout class='monospaced'>
BBLAYERS = " \
/home/scottrif/poky/meta \
- /home/scottrif/poky/meta-yocto \
+ /home/scottrif/poky/meta-poky \
/home/scottrif/poky/meta-yocto-bsp \
/home/scottrif/poky/meta-mykernel \
"
@@ -3112,7 +3112,7 @@
For example, the distribution configuration file for the
Poky distribution is named <filename>poky.conf</filename>
and resides in the
- <filename>meta-yocto/conf/distro</filename> directory of
+ <filename>meta-poky/conf/distro</filename> directory of
the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
</para>
@@ -6035,7 +6035,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
<para>
See the
- <ulink url='&YOCTO_GIT_URL;/cgit/cgit.cgi/poky/tree/meta-yocto/conf/local.conf.sample.extended'><filename>local.conf.sample.extended</filename></ulink>
+ <ulink url='&YOCTO_GIT_URL;/cgit/cgit.cgi/poky/tree/meta-poky/conf/local.conf.sample.extended'><filename>local.conf.sample.extended</filename></ulink>
file for additional information.
You can also reference the
<ulink url='&YOCTO_GIT_URL;/cgit/cgit.cgi/poky/tree/meta/classes/kernel.bbclass'><filename>kernel.bbclass</filename></ulink>
@@ -6089,7 +6089,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
You cannot set the variable in a recipe file.
</note>
See the
- <ulink url='&YOCTO_GIT_URL;/cgit/cgit.cgi/poky/tree/meta-yocto/conf/local.conf.sample.extended'><filename>local.conf.sample.extended</filename></ulink>
+ <ulink url='&YOCTO_GIT_URL;/cgit/cgit.cgi/poky/tree/meta-poky/conf/local.conf.sample.extended'><filename>local.conf.sample.extended</filename></ulink>
file for additional information.
</para>
</glossdef>
@@ -7781,7 +7781,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
is "poky", the default value for
<filename>MIRRORS</filename> is defined in the
<filename>conf/distro/poky.conf</filename> file in the
- <filename>meta-yocto</filename> Git repository.
+ <filename>meta-poky</filename> Git repository.
</para>
</glossdef>
</glossentry>
@@ -9640,7 +9640,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
is "poky", the default value for
<filename>PREMIRRORS</filename> is defined in the
<filename>conf/distro/poky.conf</filename> file in the
- <filename>meta-yocto</filename> Git repository.
+ <filename>meta-poky</filename> Git repository.
</para>
<para>
@@ -11126,7 +11126,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
<!-- <para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" /> -->
Specifies the version of the SDK.
The distribution configuration file (e.g.
- <filename>/meta-yocto/conf/distro/poky.conf</filename>)
+ <filename>/meta-poky/conf/distro/poky.conf</filename>)
defines the <filename>SDK_VERSION</filename> as follows:
<literallayout class='monospaced'>
SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
@@ -14345,7 +14345,7 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
</literallayout>
For more information, see
- <filename>meta-yocto/conf/local.conf.sample</filename> in
+ <filename>meta-poky/conf/local.conf.sample</filename> in
the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>.
</para>
diff --git a/documentation/toaster-manual/toaster-manual-reference.xml b/documentation/toaster-manual/toaster-manual-reference.xml
index cb27107143..3a46b61b73 100644
--- a/documentation/toaster-manual/toaster-manual-reference.xml
+++ b/documentation/toaster-manual/toaster-manual-reference.xml
@@ -172,9 +172,9 @@
<listitem><para>
The first version of the file is found in the
<filename>conf</filename> directory of the
- <filename>meta-yocto</filename> layer
+ <filename>meta-poky</filename> layer
(i.e.
- <filename>meta-yocto/conf/toasterconf.json</filename>).
+ <filename>meta-poky/conf/toasterconf.json</filename>).
This version contains the default Yocto Project
configuration for Toaster.
</para></listitem>
@@ -214,10 +214,10 @@
"dirpath": "meta"
},
{
- "name": "meta-yocto",
- "local_path": "meta-yocto",
+ "name": "meta-poky",
+ "local_path": "meta-poky",
"vcs_url": "remote:origin",
- "dirpath": "meta-yocto"
+ "dirpath": "meta-poky"
},
{
"name": "meta-yocto-bsp",
@@ -293,10 +293,10 @@
<filename>toasterconf.json</filename> file you just edited.
For example, if you cloned the
<filename>poky</filename> repository and you edited the
- <filename>meta-yocto/conf/toasterconf.json</filename> file,
+ <filename>meta-poky/conf/toasterconf.json</filename> file,
you would type something like the following:
<literallayout class='monospaced'>
- $ bitbake/lib/toaster/manage.py loadconf /home/scottrif/poky/meta-yocto/conf/toasterconf.json
+ $ bitbake/lib/toaster/manage.py loadconf /home/scottrif/poky/meta-poky/conf/toasterconf.json
</literallayout>
After entering this command, you need to update the
Toaster database with the information coming from your
@@ -575,9 +575,9 @@
<itemizedlist>
<listitem><para>
The
- <filename>meta-yocto/conf/toasterconf.json</filename>
+ <filename>meta-poky/conf/toasterconf.json</filename>
in the <filename>conf</filename> directory of the
- Yocto Project's <filename>meta-yocto</filename> layer.
+ Yocto Project's <filename>meta-poky</filename> layer.
This version contains the default Yocto Project
configuration for Toaster.
You are prompted to select this file during the Toaster
@@ -698,10 +698,10 @@
"dirpath": "meta"
},
{
- "name": "meta-yocto",
- "local_path": "meta-yocto",
+ "name": "meta-poky",
+ "local_path": "meta-poky",
"vcs_url": "remote:origin",
- "dirpath": "meta-yocto"
+ "dirpath": "meta-poky"
},
{
"name": "meta-yocto-bsp",
@@ -817,7 +817,7 @@
"description": "Yocto Project master",
"bitbake": "master",
"branch": "master",
- "defaultlayers": [ "openembedded-core", "meta-yocto", "meta-yocto-bsp"],
+ "defaultlayers": [ "openembedded-core", "meta-poky", "meta-yocto-bsp"],
"layersourcepriority": { "Imported layers": 99, "Local Yocto Project" : 10, "OpenEmbedded" : 0 },
"helptext": "Toaster will run your builds using the tip of the &lt;a href=\"http://git.yoctoproject.org/cgit/cgit.cgi/poky/log/\"&gt;Yocto Project master branch&lt;/a&gt;, where active development takes place. This is not a stable branch, so your builds might not work as expected."
},
@@ -826,7 +826,7 @@
"description": "Yocto Project 2.0 Jethro",
"bitbake": "jethro",
"branch": "jethro",
- "defaultlayers": [ "openembedded-core", "meta-yocto", "meta-yocto-bsp"],
+ "defaultlayers": [ "openembedded-core", "meta-poky", "meta-yocto-bsp"],
"layersourcepriority": { "Imported layers": 99, "Local Yocto Project" : 10, "OpenEmbedded" : 0 },
"helptext": "Toaster will run your builds with the tip of the &lt;a href=\"http://git.yoctoproject.org/cgit/cgit.cgi/poky/log/?h=jethro\"&gt;Yocto Project 2.0 \"Jethro\"&lt;/a&gt; branch."
},
@@ -835,7 +835,7 @@
"description": "Yocto Project 1.8 Fido",
"bitbake": "fido",
"branch": "fido",
- "defaultlayers": [ "openembedded-core", "meta-yocto", "meta-yocto-bsp"],
+ "defaultlayers": [ "openembedded-core", "meta-poky", "meta-yocto-bsp"],
"layersourcepriority": { "Imported layers": 99, "Local Yocto Project" : 10, "OpenEmbedded" : 0 },
"helptext": "Toaster will run your builds with the tip of the &lt;a href=\"http://git.yoctoproject.org/cgit/cgit.cgi/poky/log/?h=fido\"&gt;Yocto Project 1.8 \"Fido\"&lt;/a&gt; branch."
},
@@ -844,7 +844,7 @@
"description": "Local Yocto Project",
"bitbake": "HEAD",
"branch": "HEAD",
- "defaultlayers": [ "openembedded-core", "meta-yocto", "meta-yocto-bsp"],
+ "defaultlayers": [ "openembedded-core", "meta-poky", "meta-yocto-bsp"],
"layersourcepriority": { "Imported layers": 99, "Local Yocto Project" : 10, "OpenEmbedded" : 0 },
"helptext": "Toaster will run your builds with the version of the Yocto Project you have cloned or downloaded to your computer."
}
diff --git a/documentation/toaster-manual/toaster-manual-setup-and-use.xml b/documentation/toaster-manual/toaster-manual-setup-and-use.xml
index e8fb168ce8..963b211223 100644
--- a/documentation/toaster-manual/toaster-manual-setup-and-use.xml
+++ b/documentation/toaster-manual/toaster-manual-setup-and-use.xml
@@ -316,7 +316,7 @@
$ cd /var/www/toaster/poky/
$ ./bitbake/lib/toaster/manage.py syncdb
$ ./bitbake/lib/toaster/manage.py migrate
- $ TOASTER_DIR=`pwd` TOASTER_CONF=./meta-yocto/conf/toasterconf.json ./bitbake/lib/toaster/manage.py checksettings
+ $ TOASTER_DIR=`pwd` TOASTER_CONF=./meta-poky/conf/toasterconf.json ./bitbake/lib/toaster/manage.py checksettings
$ ./bitbake/lib/toaster/manage.py collectstatic
</literallayout>
</para>