aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch26
-rw-r--r--meta/recipes-devtools/strace/strace_4.10.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch b/meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch
new file mode 100644
index 0000000000..4b1bb26bb3
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace/define-OS-ARCH-in-tests-Makefile-am.patch
@@ -0,0 +1,26 @@
+Ensure that OS and ARCH are defined in tests/Makefile.am
+
+For strace v4.10 this is a purely cosmetic fix, since the include
+paths derived from $(OS)/${ARCH) are never used. These variables are
+correctly defined by default in strace v4.11.
+
+Partial backport of upstream commit:
+
+ http://sourceforge.net/p/strace/code/ci/25c804ce42261b24b19d35c637bf2745c237ee07
+
+Upstream-Status: Backport
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+
+Index: strace-4.10/tests/Makefile.am
+===================================================================
+--- strace-4.10.orig/tests/Makefile.am
++++ strace-4.10/tests/Makefile.am
+@@ -1,5 +1,7 @@
+ # Automake input for strace tests.
+
++OS = linux
++ARCH = @arch@
+ AM_CFLAGS = $(WARN_CFLAGS)
+ AM_CPPFLAGS = -I$(top_builddir)/$(OS)/$(ARCH) \
+ -I$(top_srcdir)/$(OS)/$(ARCH) \
diff --git a/meta/recipes-devtools/strace/strace_4.10.bb b/meta/recipes-devtools/strace/strace_4.10.bb
index 0b2316b402..1b6474347a 100644
--- a/meta/recipes-devtools/strace/strace_4.10.bb
+++ b/meta/recipes-devtools/strace/strace_4.10.bb
@@ -12,6 +12,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
file://run-ptest \
file://Include-sys-stat.h-for-S_I-macros.patch \
file://Include-linux-ioctl.h-for-_IOC_-macros.patch \
+ file://define-OS-ARCH-in-tests-Makefile-am.patch \
"
SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
@@ -37,7 +38,7 @@ do_install_append() {
}
do_compile_ptest() {
- oe_runmake -C ${TESTDIR} buildtest-TESTS OS=linux ARCH="${TARGET_ARCH}"
+ oe_runmake -C ${TESTDIR} buildtest-TESTS
}
do_install_ptest() {