aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch b/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch
index f53a8994fc..40c783212a 100644
--- a/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch
+++ b/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch
@@ -15454,60 +15454,6 @@ Index: git/sysdeps/gnu/Makefile
pututxline utmpxname updwtmpx getutmpx getutmp
sysdep_headers += utmpx.h bits/utmpx.h
-Index: git/sysdeps/ieee754/dbl-64/s_sin.c
-===================================================================
---- git.orig/sysdeps/ieee754/dbl-64/s_sin.c 2014-08-29 20:00:54.260070587 -0700
-+++ git/sysdeps/ieee754/dbl-64/s_sin.c 2014-08-29 20:01:15.240070587 -0700
-@@ -447,21 +447,19 @@
- }
- else
- {
-- double t;
- if (a > 0)
- {
- m = 1;
-- t = a;
- db = da;
- }
- else
- {
- m = 0;
-- t = -a;
-+ a = -a;
- db = -da;
- }
-- u.x = big + t;
-- y = t - (u.x - big);
-+ u.x = big + a;
-+ y = a - (u.x - big);
- res = do_sin (u, y, db, &cor);
- cor = (cor > 0) ? 1.035 * cor + eps : 1.035 * cor - eps;
- retval = ((res == res + cor) ? ((m) ? res : -res)
-@@ -673,21 +671,19 @@
- }
- else
- {
-- double t;
- if (a > 0)
- {
- m = 1;
-- t = a;
- db = da;
- }
- else
- {
- m = 0;
-- t = -a;
-+ a = -a;
- db = -da;
- }
-- u.x = big + t;
-- y = t - (u.x - big);
-+ u.x = big + a;
-+ y = a - (u.x - big);
- res = do_sin (u, y, db, &cor);
- cor = (cor > 0) ? 1.035 * cor + eps : 1.035 * cor - eps;
- retval = ((res == res + cor) ? ((m) ? res : -res)
Index: git/sysdeps/ieee754/ldbl-opt/Makefile
===================================================================
--- git.orig/sysdeps/ieee754/ldbl-opt/Makefile 2014-08-29 20:00:54.452070587 -0700