aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/opkg/opkg-config-base_1.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
index 3a559cb57d..f37b2db27d 100644
--- a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
+++ b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
@@ -9,7 +9,12 @@ do_compile() {
archconf=${S}/${sysconfdir}/opkg/arch.conf
rm -f $archconf
- ipkgarchs="${PACKAGE_ARCHS}"
+ multilibs="${@d.getVar('MULTILIBS',True)}"
+ if [ "X${multilibs}" == "XNone" ]; then
+ ipkgarchs="${PACKAGE_ARCHS}"
+ else
+ ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
+ fi
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> $archconf