aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/cups/cups.inc14
1 files changed, 2 insertions, 12 deletions
diff --git a/meta/recipes-extended/cups/cups.inc b/meta/recipes-extended/cups/cups.inc
index df47c81d59..ba50296ba7 100644
--- a/meta/recipes-extended/cups/cups.inc
+++ b/meta/recipes-extended/cups/cups.inc
@@ -43,13 +43,7 @@ EXTRA_OECONF = " \
--without-java \
"
-
-do_configure() {
- gnu-configize
- libtoolize --force
- autoconf --force
- DSOFLAGS="${LDFLAGS}" SERVERBIN="${libdir}/cups" oe_runconf
-}
+EXTRA_AUTORECONF += "--exclude=autoheader"
do_compile () {
sed -i s:STRIP:NOSTRIP: Makedefs
@@ -63,11 +57,7 @@ do_compile () {
echo "install-headers:" >> man/Makefile
echo "install-libs:" >> man/Makefile
- oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
- "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
- "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
- "LIBZ=-lz -L${STAGING_LIBDIR}" \
- "-I."
+ oe_runmake
}
do_install () {