aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.5.bb b/meta/recipes-devtools/python/python-pycurl_7.19.5.bb
index a21a426dbb..e4619c740e 100644
--- a/meta/recipes-devtools/python/python-pycurl_7.19.5.bb
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.5.bb
@@ -29,6 +29,11 @@ export STAGING_LIBDIR
BBCLASSEXTEND = "native"
+# Ensure the docstrings are generated as make clean will remove them
+do_compile_prepend() {
+ ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
+}
+
do_install_append() {
rm -rf ${D}${datadir}/share
}