aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-03-18 19:03:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:54:22 +0000
commita785a9d9aff97ae3ddde460474825be28c36009c (patch)
tree2f1b0ef7bc2bcd50b0c6c4ecb714890e28636eb4 /scripts
parent15ab96040f244d398954363f09e5a8110076fd29 (diff)
downloadopenembedded-core-contrib-a785a9d9aff97ae3ddde460474825be28c36009c.tar.gz
layer.conf: avoid unnecessary early expansion with :=
bitbake handles immediate expansions of LAYERDIR for us automatically. (From meta-yocto rev: ee59f1ec94ba8474876603dad1ab32d131227f49) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/common/conf/layer.conf6
-rw-r--r--scripts/lib/bsp/substrate/target/arch/layer/conf/layer.conf6
2 files changed, 6 insertions, 6 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/common/conf/layer.conf b/scripts/lib/bsp/substrate/target/arch/common/conf/layer.conf
index 921d976dce..97029dd7e4 100644
--- a/scripts/lib/bsp/substrate/target/arch/common/conf/layer.conf
+++ b/scripts/lib/bsp/substrate/target/arch/common/conf/layer.conf
@@ -1,10 +1,10 @@
# We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "{{=machine}}"
-BBFILE_PATTERN_{{=machine}} := "^${LAYERDIR}/"
+BBFILE_PATTERN_{{=machine}} = "^${LAYERDIR}/"
BBFILE_PRIORITY_{{=machine}} = "6"
diff --git a/scripts/lib/bsp/substrate/target/arch/layer/conf/layer.conf b/scripts/lib/bsp/substrate/target/arch/layer/conf/layer.conf
index 84a9abb1d0..76153f3f8f 100644
--- a/scripts/lib/bsp/substrate/target/arch/layer/conf/layer.conf
+++ b/scripts/lib/bsp/substrate/target/arch/layer/conf/layer.conf
@@ -1,10 +1,10 @@
# We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "{{=layer_name}}"
-BBFILE_PATTERN_{{=layer_name}} := "^${LAYERDIR}/"
+BBFILE_PATTERN_{{=layer_name}} = "^${LAYERDIR}/"
BBFILE_PRIORITY_{{=layer_name}} = "{{=layer_priority}}"