aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-08-05 14:50:14 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:20:10 +0100
commit4df9f11171530ca60043504ce011f34c42e93b46 (patch)
tree81b6b7b565e7645d44d391da0bf80cf897842a34 /scripts
parent6ea1ed5f7b51b7c04e8aca29319c970846ddf1b8 (diff)
downloadopenembedded-core-contrib-4df9f11171530ca60043504ce011f34c42e93b46.tar.gz
poky-qemu-internal: Support NFS boots better
The image specification can now be in the form nfs-server:directory. This makes it possible to nfs-boot from servers other than the host. poky-qemu-internal will properly construct the kernel command line given such a specification. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/poky-qemu-internal24
-rw-r--r--scripts/tunctl-src/Makefile17
2 files changed, 31 insertions, 10 deletions
diff --git a/scripts/poky-qemu-internal b/scripts/poky-qemu-internal
index 8ff3add511..acb6ff50ff 100755
--- a/scripts/poky-qemu-internal
+++ b/scripts/poky-qemu-internal
@@ -92,6 +92,16 @@ if [ "$TYPE" != "nfs" -a ! -f "$HDIMAGE" ]; then
return
fi
+if [ "$TYPE" = "nfs" ]; then
+ NFS_SERVER=`echo $HDIMAGE | sed 's/^\([^:]*\):.*/\1/'`
+ NFS_DIR=`echo $HDIMAGE | sed 's/^[^:]*:\(.*\)/\1/'`
+fi
+
+if [ "$NFS_SERVER" = "" ]; then
+ NFS_SERVER="192.168.7.1"
+ NFS_DIR=$HDIMAGE
+fi
+
if [ ! -f "$ZIMAGE" ]; then
echo "Error: Kernel image file $ZIMAGE doesn't exist"
return
@@ -107,14 +117,11 @@ if [ "$MACHINE" = "qemuarm" -o "$MACHINE" = "qemuarmv6" -o "$MACHINE" = "qemuarm
QEMUOPTIONS="$QEMU_NETWORK_CMD -M versatilepb -hda $HDIMAGE -no-reboot $QEMU_UI_OPTIONS"
fi
if [ "$TYPE" = "nfs" ]; then
- if [ "x$HDIMAGE" = "x" ]; then
- HDIMAGE=/srv/nfs/qemuarm
- fi
- if [ ! -d "$HDIMAGE" ]; then
+ if [ "$NFS_SERVER" = "192.168.7.1" -a ! -d "$NFS_DIR" ]; then
echo "Error: NFS mount point $HDIMAGE doesn't exist"
return
fi
- KERNCMDLINE="root=/dev/nfs nfsroot=192.168.7.1:$HDIMAGE rw $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
+ KERNCMDLINE="root=/dev/nfs nfsroot=$NFS_SERVER:$NFS_DIR rw $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
QEMUOPTIONS="$QEMU_NETWORK_CMD -M versatilepb --no-reboot $QEMU_UI_OPTIONS"
fi
if [ "$MACHINE" = "qemuarmv6" ]; then
@@ -133,14 +140,11 @@ if [ "$MACHINE" = "qemux86" ]; then
QEMUOPTIONS="$QEMU_NETWORK_CMD -hda $HDIMAGE $QEMU_UI_OPTIONS"
fi
if [ "$TYPE" = "nfs" ]; then
- if [ "x$HDIMAGE" = "x" ]; then
- HDIMAGE=/srv/nfs/qemux86
- fi
- if [ ! -d "$HDIMAGE" ]; then
+ if [ "$NFS_SERVER" = "192.168.7.1" -a ! -d "$NFS_DIR" ]; then
echo "Error: NFS mount point $HDIMAGE doesn't exist."
return
fi
- KERNCMDLINE="root=/dev/nfs nfsroot=192.168.7.1:$HDIMAGE rw $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
+ KERNCMDLINE="root=/dev/nfs nfsroot=$NFS_SERVER:$NFS_DIR rw $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
QEMUOPTIONS="$QEMU_NETWORK_CMD $QEMU_UI_OPTIONS"
fi
fi
diff --git a/scripts/tunctl-src/Makefile b/scripts/tunctl-src/Makefile
new file mode 100644
index 0000000000..81cab8a3cd
--- /dev/null
+++ b/scripts/tunctl-src/Makefile
@@ -0,0 +1,17 @@
+OBJS = tunctl.o
+BIN = tunctl
+CFLAGS ?= -g -Wall
+
+BIN_DIR ?= /usr/bin
+
+all : $(BIN)
+
+$(BIN) : $(OBJS)
+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
+
+clean :
+ rm -f $(BIN) $(OBJS) *~
+
+install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+ install -s $(BIN) $(DESTDIR)$(BIN_DIR)