aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-05-01 09:49:43 +0000
committerRichard Purdie <richard@openedhand.com>2008-05-01 09:49:43 +0000
commitd9bb8113c53339f9b30a357f21e2eb269957e56e (patch)
tree38331f1faa04e60cadc0dc36149ce5a31961c926 /scripts
parent732e3cab7a9f6d18d59adba0e5dc17720b6f7e19 (diff)
downloadopenembedded-core-contrib-d9bb8113c53339f9b30a357f21e2eb269957e56e.tar.gz
scripts: Add meta-darwin build to the autobuilder
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4380 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/poky-autobuild20
-rw-r--r--scripts/pokyABConfig.py18
2 files changed, 37 insertions, 1 deletions
diff --git a/scripts/poky-autobuild b/scripts/poky-autobuild
index 48c7df8403..0585790506 100755
--- a/scripts/poky-autobuild
+++ b/scripts/poky-autobuild
@@ -28,6 +28,8 @@ elif [ "$CURRDIR" = "/srv/poky/autobuild/toolchain-shihtzu/build" ]; then
ABTARGET="toolchain"
elif [ "$CURRDIR" = "/srv/poky/autobuild/incremental-shihtzu/build" ]; then
ABTARGET="incremental"
+elif [ "$CURRDIR" = "/srv/poky/autobuild/full-darwin-shihtzu/build" ]; then
+ ABTARGET="darwin"
fi
if [ "xpreamble" = "x$1" ]; then
@@ -61,6 +63,24 @@ if [ ! -e "$CONFFILE" ]; then
echo 'BB_NUMBER_THREADS = "6"' >> "$CONFFILE"
echo 'PARALLEL_MAKE = "-j 6"' >> "$CONFFILE"
echo 'DL_DIR = "/srv/poky/sources"' >> "$CONFFILE"
+ if [ "$ABTARGET" = "darwin" ]; then
+ if [ ! -d "$CURRDIR/meta-darwin" ]; then
+ svn co http://svn.o-hand.com/repos/poky/branches/experimental/meta-darwin $CURRDIR/meta-darwin
+ else
+ cd $CURRDIR/meta-darwin
+ svn up
+ fi
+ echo 'PACKAGE_CLASSES += "package_tar"' > "$CONFFILE"
+ echo "BBFILES += \"$CURRDIR/meta-darwin/packages/*/*.bb\"" > "$CONFFILE"
+ echo 'POKYMODE = "darwin"' > "$CONFFILE"
+ echo 'DARWINFILES = "file:///srv/poky/sources/"' > "$CONFFILE"
+ echo 'INHERIT_INSANE = ""' > "$CONFFILE"
+ echo 'FILESPATH_append = ":$CURRDIR/meta-darwin/files"' > "$CONFFILE"
+ fi
+fi
+
+if [ "$ABTARGET" = "darwin" ]; then
+ BBPATH=$CURRDIR/meta-darwin:$BBPATH
fi
bitbake $@
diff --git a/scripts/pokyABConfig.py b/scripts/pokyABConfig.py
index 1b5aec0653..00898d49df 100644
--- a/scripts/pokyABConfig.py
+++ b/scripts/pokyABConfig.py
@@ -101,6 +101,16 @@ runImage(f6, 'qemux86', 'meta-toolchain-sdk')
runImage(f6, 'qemuarm', 'world -c checkuriall')
runComplete(f6)
+from buildbot.process import step, factory
+f7 = factory.BuildFactory()
+f7.addStep(step.SVN, svnurl="http://svn.o-hand.com/repos/poky/trunk", mode="copy", timeout=10000)
+runPreamble(f7)
+defaultenv['DISTRO'] = 'poky'
+defaultenv['POKYLIBC'] = 'dummy'
+runImage(f7, 'ipodtouch', 'meta-clutter')
+defaultenv['POKYLIBC'] = 'glibc'
+runComplete(f7)
+
#from buildbot.process import step, factory
#f7 = factory.BuildFactory()
#f7.addStep(step.SVN, svnurl="http://svn.o-hand.com/repos/poky/trunk", timeout=10000)
@@ -134,11 +144,17 @@ b6 = {'name': "poky-toolchain-shihtzu",
'factory': f6
}
+b7 = {'name': "poky-full-darwin-shihtzu",
+ 'slavename': "shihtzu-autobuild",
+ 'builddir': "full-darwin-shihtzu",
+ 'factory': f7
+ }
+
#b7 = {'name': "poky-incremental-world-shihtzu",
# 'slavename': "shihtzu-autobuild",
# 'builddir': "incremental-world-shihtzu",
# 'factory': f7
# }
-poky_builders = [b3, b4, b5, b6]
+poky_builders = [b3, b4, b5, b6, b7]