aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-08-31 15:15:55 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-08 00:36:43 +0100
commit2600cd6f6c63ecf79804e2bc6eb6f198a012d5d6 (patch)
tree7e01154a29f8f2d9af5444a5a5f0774f0d3128be /scripts
parent9069fef5dad5a873c8a8f720f7bcbc7625556309 (diff)
downloadopenembedded-core-contrib-2600cd6f6c63ecf79804e2bc6eb6f198a012d5d6.tar.gz
recipetool: create: AX_PKG_SWIG should add dependency on swig-native
If AX_PKG_SWIG is found in configure.ac, then what's being looked for is the swig binary, not swig for the target - so fix the dependency accordingly. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/recipetool/create_buildsys.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/recipetool/create_buildsys.py b/scripts/lib/recipetool/create_buildsys.py
index f784f9468a..0ad748ef02 100644
--- a/scripts/lib/recipetool/create_buildsys.py
+++ b/scripts/lib/recipetool/create_buildsys.py
@@ -570,7 +570,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
elif keyword == 'AX_LIB_TAGLIB':
deps.append('taglib')
elif keyword == 'AX_PKG_SWIG':
- deps.append('swig')
+ deps.append('swig-native')
elif keyword == 'AX_PROG_XSLTPROC':
deps.append('libxslt-native')
elif keyword == 'AX_WITH_CURSES':