aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2015-03-07 09:54:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-16 17:38:32 +0000
commitf76572df61d27a7e25f8433b1bbf42a0c9032024 (patch)
treeb9eae082cc2a2ff0c1bbf38a0d529b3cc0565413 /scripts
parent49ed897c01cb3be7582f79d863110688cc46dc55 (diff)
downloadopenembedded-core-contrib-f76572df61d27a7e25f8433b1bbf42a0c9032024.tar.gz
test-dependencies.sh: strip only .bb suffix
* we were stripping too much when stripping recipe name from line like this: ERROR: Task 12016 (/some/patch/something.dot.bar.bb, do_fetch) failed with exit code '1' where the recipe name contains dots and doesn't end with _<version>.bb * apply the same fix as 8c9a25ae70d249b823ab2b0385d539eb8bbc1374 while building individual recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/test-dependencies.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/test-dependencies.sh b/scripts/test-dependencies.sh
index e01acbecf7..0170947f0e 100755
--- a/scripts/test-dependencies.sh
+++ b/scripts/test-dependencies.sh
@@ -178,7 +178,7 @@ build_every_recipe() {
RESULT+=${RECIPE_RESULT}
mv ${OUTPUTB}/${recipe}.log ${OUTPUTB}/failed/
grep "ERROR: Task.*failed" ${OUTPUTB}/failed/${recipe}.log | tee -a ${OUTPUTB}/failed-tasks.log
- grep "ERROR: Task.*failed" ${OUTPUTB}/failed/${recipe}.log | sed 's@.*/@@g; s@_.*@@g; s@\..*@@g' >> ${OUTPUTB}/failed-recipes.log
+ grep "ERROR: Task.*failed" ${OUTPUTB}/failed/${recipe}.log | sed 's@.*/@@g; s@_.*@@g; s@\.bb, .*@@g' >> ${OUTPUTB}/failed-recipes.log
# and append also ${recipe} in case the failed task was from some dependency
echo ${recipe} >> ${OUTPUTB}/failed-recipes.log
else