aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-04-27 10:53:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 15:05:40 +0100
commitbdbeff0cd342e31053d7203d78fc5dda611052b1 (patch)
tree585a5a2f7bbe4f85de7ea6a410b0b997ed9be582 /scripts
parentb9fd8d4d4dfae72de2e81e9b14de072e12cecdcf (diff)
downloadopenembedded-core-contrib-bdbeff0cd342e31053d7203d78fc5dda611052b1.tar.gz
devtool: add: use correct bbappend file name with -V option
We weren't adding the version into the bbappend file name when -V was specified which meant that building or resetting failed. Also adjust one of the tests so that we're testing devtool add both with and without this option. Fixes [YOCTO #7647]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/devtool/standard.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/devtool/standard.py b/scripts/lib/devtool/standard.py
index faf5c92176..893226578a 100644
--- a/scripts/lib/devtool/standard.py
+++ b/scripts/lib/devtool/standard.py
@@ -73,7 +73,7 @@ def add(args, config, basepath, workspace):
(stdout, _) = bb.process.run('git rev-parse HEAD', cwd=srctree)
initial_rev = stdout.rstrip()
- appendfile = os.path.join(appendpath, '%s.bbappend' % args.recipename)
+ appendfile = os.path.join(appendpath, '%s.bbappend' % bp)
with open(appendfile, 'w') as f:
f.write('inherit externalsrc\n')
f.write('EXTERNALSRC = "%s"\n' % srctree)